是否有一个多操作系统蓝牙库?

我在一个随意的devise阶段,我有硬件devise和蓝牙通信。 我想用一个程序来支持OSX,Windows和Linux。 我发现bluecove库,但其最后的版本是2008年,所以我不知道是否过时或支持BT 4.0。

最后,如果不可能,那么我想我会为它创build个人解决scheme。 到目前为止,我只find了C#的32feet 。

有什么build议么?

Solutions Collecting From Web of "是否有一个多操作系统蓝牙库?"

Qt蓝牙模块看起来很有希望,但是它仍然不支持 Qt 5.0中的 Windows / Mac / Linux

看来,支持BLE(蓝牙低功耗)将会包含在Qt 5.3中。

不幸的是,现在没有可用于Windows / Mac / Linux的跨平台蓝牙库

我需要一个支持Android,iOS,OS X,Linux,Windows的C或C ++蓝牙库。 到目前为止我还没有找到解决办法。 Qt 5.4在Android和Linux上运行得不错,但是不会支持iOS,OS X和Windows。

也许为iOS,OS X和Windows实现BlueZ接口可能是有道理的。 我期望这个任务不会是微不足道的。

http://www.bluez.org/

-ed