Berkeley DB不匹配错误,同时configurationLDAP

我正在configurationOPENLDAP 2.4.35。 在Redhat Linux上,我已经安装了Berkley DB 4.8.30作为先决条件。 我还从OPENLDAP的README文件中检查了版本兼容性,该文件说:

SLAPD: BDB and HDB backends require Oracle Berkeley DB 4.4 - 4.8, or 5.0 - 5.1. It is highly recommended to apply the patches from Oracle for a given release. 

还是我得到这个错误:

  checking db.h usability... yes checking db.h presence... yes checking for db.h... yes checking for Berkeley DB major version in db.h... 4 checking for Berkeley DB minor version in db.h... 8 checking if Berkeley DB version supported by BDB/HDB backends... yes checking for Berkeley DB link (-ldb-4.8)... yes *checking for Berkeley DB library and header version match... no configure: error: Berkeley DB version mismatch* 

请帮助

Solutions Collecting From Web of "Berkeley DB不匹配错误,同时configurationLDAP"