无法在centos 6.5上安装python-dev

无法在centos 6.5上安装python-dev。 百胜说:“没有可用的软件包python-dev。” 请没有graphics解决scheme。

Solutions Collecting From Web of "无法在centos 6.5上安装python-dev"

在CentOS上,python开发库的名称是python-devel ,而不是python-dev

所以你应该使用

 sudo yum install python-devel 

把它们安装在你的CentOS系统上。

您可以使用yum search xxxxx命令yum search xxxxx可用的存储库,其中xxxxx是要查找的包的名称或部分名称。

此外,您可能需要指定体系结构(如python-devel.x86_64),尽管根据我的经验,yum会自动安装适合您系统的软件包。 再次, yum search会显示你当前安装/启用的存储库中可用的内容。

你试过了吗

yum groupinstall -y 'development tools'

你有没有尝试下载RPM软件包并安装它?

你有没有尝试安装python-pip然后发出pip install python-dev