不能使用CONFIG_CC_STACKPROTECTOR_STRONG:-fstack-protector-strong不受编译器支持

我在我的笔记本电脑上运行Ubuntu 16.10;
我最近从git下载了Linux内核,但是当我试图用make命令从terminal进行编译时。

这是给我的

 "error:Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong not supported by compiler" 

我该怎么办才能解决这个问题?

Solutions Collecting From Web of "不能使用CONFIG_CC_STACKPROTECTOR_STRONG:-fstack-protector-strong不受编译器支持"

看到这个线程和这个答案 :这个错误可能是多个gcc版本替代品的结果。
请参阅“ update-alternatives做什么? ”

清除它们:

 $ sudo update-alternatives --remove-all gcc $ sudo update-alternatives --remove-all g++ 

然后重新安装它们,并确保你的gcc和g ++引用了相同的版本。

 sudo update-alternatives --config gcc sudo update-alternatives --config g++ 

注(2017年3月): doug65536 在评论中提到另一个案例:

我发现我的NVIDIA驱动程序包的问题的解决方案。
我已经为gdb补丁安装了binutils的自定义版本。
强制它重新安装binutils解决了这个问题。 这是没有道理的,但它的工作。