如何在安装gem时包含x86-mingw32二进制文件

在Windows 7上,使用ruby 2.1.6:我尝试安装gtk3:gem install gtk3

C:\>gem install gtk3 Fetching: pkg-config-1.1.6.gem (100%) Successfully installed pkg-config-1.1.6 Fetching: cairo-1.14.1-x86-mingw32.gem (100%) Successfully installed cairo-1.14.1-x86-mingw32 Fetching: glib2-2.2.5-x86-mingw32.gem (100%) Successfully installed glib2-2.2.5-x86-mingw32 Fetching: gobject-introspection-2.2.5-x86-mingw32.gem (100%) Successfully installed gobject-introspection-2.2.5-x86-mingw32 Fetching: gio2-2.2.5-x86-mingw32.gem (100%) Successfully installed gio2-2.2.5-x86-mingw32 Fetching: atk-2.2.5-x86-mingw32.gem (100%) Successfully installed atk-2.2.5-x86-mingw32 Fetching: pango-2.2.5-x86-mingw32.gem (100%) Successfully installed pango-2.2.5-x86-mingw32 Fetching: gdk_pixbuf2-2.2.5-x86-mingw32.gem (100%) Successfully installed gdk_pixbuf2-2.2.5-x86-mingw32 Fetching: cairo-gobject-2.2.5-x86-mingw32.gem (100%) Successfully installed cairo-gobject-2.2.5-x86-mingw32 Fetching: gdk3-2.2.5-x86-mingw32.gem (100%) Successfully installed gdk3-2.2.5-x86-mingw32 Fetching: gtk3-2.2.5.gem (100%) ERROR: Error installing gtk3: The 'gtk3' native gem requires installed build tools. 

所以现在我注意到它正在安装所有的gem,它会得到一个带-x86-mingw32的版本作为它的一部分。 除了gtk3,它说:gtk3-2.2.5.gem,没有-x86-mingw32。

所以我的问题:我如何强制安装程序下载与-x86-mingw32的版本? 或者事实并非如此,这是否意味着没有这样的gem。

如果没有,我怎么能find以前的版本包括二进制文件作为gem的一部分,即-x86-mingw32

谢谢

Solutions Collecting From Web of "如何在安装gem时包含x86-mingw32二进制文件"

所以这是超级怪异的。 它看起来像Ruby 2.1.6的版本中有一个错误,导致它做奇怪的事情。 可能与rubygems 2.3.0platforms更新有关。

无论如何,有一个二进制版本的gtk3可用,但你必须更新rubygems尝试做的gem update --system ,再次安装gtk3

注意:您可以使用rubygems网站检查可用的gem版本。 这里是可用的gtk3版本 。