GTK +安装

我正在使用Ubuntu 12.10。 我有代码:块IDE。 我想使用gtk +,但是当我创build一个项目,并build立它说它找不到gtk.h文件。

我通过编写下载了gtk +,glib,pango,gdk-pixbuf和atk

git clone git://git.gnome.org/gtk+, git clone git://git.gnome.org/glib ... 

然后我解压所有库。 在这里,每件事情都很好。

要安装gtk +我写“./configure –prefix = / opt / gtk”它开始处理,大部分的过程都可以,但是它带有一个错误

 ... checking for some Win32 platform... no checking whether build environment is sane... yes checking for pkg-config... /usr/bin/pkg-config checking pkg-config is at least version 0.9.0... yes checking for BASE_DEPENDENCIES... no configure: error: Package requirements (glib-2.0 >= 2.33.1 atk >= 2.5.3 pango >= 1.30.0 cairo >= 1.10.0 cairo-gobject >= 1.10.0 gdk-pixbuf-2.0 >= 2.26.0) were not met: No package 'glib-2.0' found No package 'atk' found No package 'pango' found No package 'cairo' found No package 'cairo-gobject' found No package 'gdk-pixbuf-2.0' found Consider adjusting the PKG_CONFIG_PATH environment variable if you installed software in a non-standard prefix. Alternatively, you may set the environment variables BASE_DEPENDENCIES_CFLAGS and BASE_DEPENDENCIES_LIBS to avoid the need to call pkg-config. See the pkg-config man page for more details. 

我试图通过在其目录中编写./configure来安装其他库。 但是它不能文件configuration文件。

我设置了PKG_CONFIG_PATH但是它不起作用

我怎样才能安装它?

Solutions Collecting From Web of "GTK +安装"

你不需要git clone步骤。 这只有在你想重建GTK +的时候才需要。

你想要的是你的Linux发行版的开发包。 在你的包中搜索类似libgtk*-dev东西,然后安装它。 这将安装你需要的头文件和所有的依赖关系。 此外, pkg-config将不需要任何提示来查找描述如何构建应用程序并将其链接到这些库的.pc文件,因此不需要配置PKG_CONFIG_PATH

你应该使用:apt-get install libgtk2.0-dev

你也可以按照gnome.org的建议使用jhbuild,它会自动安装依赖关系。

我已经通过这个。 这是因为IDE(你的情况Code :: Bloks)没有设置为编译gtk库。 您需要在终端中手动编译它:

 gcc `pkg-config --cflags gtk+-2.0` -o nameOfYourFile nameOfYoutFile.c `pkg-config --libs gtk+-2.0` 

你可以在代码块或终端中运行它。