安装json gem时出错:“json”原生gem需要安装构build工具

当我试图安装这个gem声称,我需要有一个开发板安装,虽然我相信我确实有它。 这也表明,我需要更新我的系统variables,我已经直接链接到ruby的devkit文件。 我已经看到堆栈溢出的其他问题,他们没有解决我的问题。 这里是完整的错误信息:

C:\Users\Mahamoud>gem install json ERROR: Error installing json: The 'json' native gem requires installed build tools. Please update your PATH to include build tools or download the DevKit from 'http://rubyinstaller.org/downloads' and follow the instructions at 'http://github.com/oneclick/rubyinstaller/wiki/Development-Kit' 

我试着卸载并重新安装ruby,仍然没有结果。 我有我的开发工具包位于C:\ Ruby193 \斌

Solutions Collecting From Web of "安装json gem时出错:“json”原生gem需要安装构build工具"