Linux上的JavaFX

Linux上的JavaFX(x86和x64)有什么情况?

JavaFX应用程序可以在Linux操作系统上正常运行吗?

我发现了2011年和2012年的一些问题,当时应用程序不稳定!

Solutions Collecting From Web of "Linux上的JavaFX"

目前JFX的版本是2.2.4,在Linux上非常稳定。 然而,当Java 8发布的时候它会变得非常好,因为它将包含JFX 8分布。 现在可以使用java 8早期访问构建自己尝试。

根据我的经验,JavaFX 8在Linux上运行良好,唯一的要求似乎是libgtk 2.18+。 有关Oracle JDK 8和JRE 8认证系统配置的详细信息 。 工作的Linux版本包括:

  • Ubuntu 10.04(可能更早,10.04有libgtk 2.20)
  • Redhat 6

可能遇到的问题

  • 3D场景支持 – 需要特定的现代GPU +最近的驱动程序,注意这里没有软件渲染的后备,也没有计划 – 查看邮件列表问题
  • 视频播放需要特定版本的libavcodec
  • OpenJDK还没有包含javafx,只有oracle分布。 2016年7月更新 – openjfx软件包现已发布。Ubuntu Ubuntu 16.04 …

Javafx像所有其他Java应用程序一样在JVM(Java虚拟机)上运行。 不管你是在windows还是linux或者mac上运行javafx应用程序,毫无疑问它都不会运行。 这就是为什么java被称为平台独立语言。 现在稳定版本的javafx 8已经发布了更多的功能。