npm安装(打字稿编译器)包的旧版本

Windows环境下,我有:节点v4.6.0 npm v3.10.8

我的本地打字稿版本是: npm run tsc -v 3.10.8

不过,我有时想使用我的全球tsc(因为某些原因,吞噬使用全球tsc),但是当我这样做时:

npm install tsc -g tsc -v我的打字机编译器版本为1.5.3

当我试图强制安装到我需要的确切版本: npm install tsc@3.10.8 -g我得到:`npm ERR! Windows_NT 10.0.14393 npm ERR! argv“C:\ Program Files \ nodejs \ node.exe”“C:\ Users \ DT \ AppData \ Roaming \ npm \ node_modules \ npm \ bin \ npm-cli.js”“install”“tsc@3.10.8” “-g”npm ERR! 节点v4.6.0 npm ERR! npm v3.10.8 npm错误! 代码ETARGET

npm ERR! notarget找不到兼容版本:tsc@3.10.8 npm ERR! notarget有效的安装目标:npm ERR! notarget 1.20150623.0,1.20150622.0,1.20150619.0,1.0.0`

顺便说一下,我的默认安装节点,我的npm版本是2东西,但我可以更新到3.10.8,这是有效的。 对于打字稿,但是,没有办法。

有任何想法吗?

PS:我的平台是Windows 10

Solutions Collecting From Web of "npm安装(打字稿编译器)包的旧版本"