PHP 5.5.0与Microsoft SQL Server 2008 R2 – 没有sqlsrv_connect()?

我有以下的环境:

  • Windows Server 2008 R2
  • IIS 7.5
  • Microsoft SQL Server 2008 R2

我想要使​​用新的PHP 5.5.0版本,它可以正常工作,但由于缺less当前的驱动程序,我无法连接到MSSQL服务器。

对于我以前的PHP 5.4.15版本,我使用了官方的微软驱动程序> here < 。

有没有可能从PHP 5.5.0连接?

Solutions Collecting From Web of "PHP 5.5.0与Microsoft SQL Server 2008 R2 – 没有sqlsrv_connect()?"

用VC11编译的PHP 5.5,所以驱动程序也必须用VC11编译。 您可以从这里下载PHP SQL server驱动程序(用VC11编译):

用于PHP 5.5的SQL server PHP驱动程序

微软的官方驱动已经发布(12/12/2014)..你可以在这里下载

版本3.1现在支持PHP 5.5,并且需要用于SQL server的Microsoft ODBC驱动程序11(或更高版本)