如何使用python2.7pip而不是默认pip

我刚刚安装了python 2.7,也点到2.7的网站包。

当我拿到版本:

pip -V 

表明:

 pip 1.3.1 from /usr/lib/python2.6/site-packages (python 2.6) 

我如何使用位于以下位置的2.7版本的pip:

 /usr/local/lib/python2.7/site-packages 

Solutions Collecting From Web of "如何使用python2.7pip而不是默认pip"

应该有一个名为“pip2.7”的二进制文件安装在$ PATH变量中包含的某个位置。

你可以通过输入找到

 which pip2.7 

这应该打印一些像'/usr/local/bin/pip2.7'到你的标准输出。 如果它不打印这样的东西,它没有安装。 在这种情况下,通过运行来安装它

 $ wget https://bootstrap.pypa.io/get-pip.py $ sudo python2.7 get-pip.py 

现在,你应该一切都安定了

 which pip2.7 

应该返回正确的输出。