R – 在Windows中安装Devtools时出错

对于R来说,我是相当新的,并且对于stackoverflow,如果我没有在下面的问题中提供足够的细节,我很抱歉。 如果需要,欢迎提供更多信息

我运行Windows 7 Professional(64位)并安装了R版本3.0.2。

当我尝试安装devtools时,我获得了

库(devtools)

警告信息:

包“devtools”是在R 3.0.3版本下构build的。build_github_devtools()

“C:/PROGRA~1/R/R-30~1.2/bin/x64/R”–vanilla CMD SHLIB foo.c

gcc -m64 -I“C:/PROGRA~1/R/R-30~1.2/include”-DNDEBUG
-I“d:/ RCompile / CRANpkg / extralibs64 / local / include”-O2 -Wall -std = gnu99 -mtune = core2 -c foo.c -o foo.o gcc -m64 -shared -s -static-libgcc – o foo.dll tmp.def foo.o -Ld:/ RCompile / CRANpkg / extralibs64 / local / lib / x64 -Ld:/ RCompile / CRANpkg / extralibs64 / local / lib -LC:/ PROGRA〜1 / R / R- 30〜1.2 / bin / x64 -lR从https://github.com/hadley/devtools/archive/master.zip下载开发工具“C:/PROGRA~1/R/R-30~1.2/bin/x64/R “–vanilla CMD INSTALL”C:\ Users \ AppData \ Local \ Temp \ Rtmp8yGaPd \ devtools-master“–build

  • 安装到库“C:/ Users / AppData / Local / Temp / Rtmp8yGaPd / file1afc11f24d1b”

错误:依赖'rversions','git2r'不可用于包'devtools'

  • 删除'C:/ Users / AppData / Local / Temp / Rtmp8yGaPd / file1afc11f24d1b / devtools'

错误:命令失败(1)

我已经search了依赖关系颠覆和git2r的帮助,但没有运气到目前为止。

有人可以帮忙吗?

Solutions Collecting From Web of "R – 在Windows中安装Devtools时出错"

这是关于git2r的信息

以下devtools安装信息来自devtools :

确保你有一个工作的开发环境。

  1. Windows:安装Rtools 。

  2. 使用install.packages("devtools")从CRAN安装devtools的发行版本。

    视窗:

    库(devtools)build_github_devtools()

    在继续之前重新启动R.

    install.packages(“devtools.zip”,repos = NULL,type =“source”)

    安装后取出包装

    取消关联( “devtools.zip”)