错误:当SDKpipe理器显示它安装时,请安装Android目标:“android-22”

我在我的环境中安装了android-22。 但仍然在运行cordova生成android获取以下错误:

C:\ Work \ WebRTC \ FirstResponder \ rtcommmobile> cordova build android运行命令:C:\ Work \ WebRTC \ nodejs \ node.exe C:\ Work \ WebRTC \ FirstResponder \ rtcommmobile \ hooks \ after_prepare \添加到body类:platform -android运行命令:C:\ Work \ WebRTC \ nodejs \ node.exe C:\ Work \ WebRTC \ FirstResponder \ rtcommmobile \ hooks \ after_prepare \运行命令:cmd“/ s / c”C:\ Work \ WebRTC \ FirstResponder \ rtcommmobile \ platforms \ android \ cordova \ build.bat“”[错误:请安装Android目标:“android-22”。

提示:通过运行以下命令打开SDKpipe理器:C:\ Work \ WebRTC \ android \ android-sdk \ tools \ android.BAT您将需要:1.“SDK Platform”for android-22 2.“Android SDK Platform-tools最新)3.“Android SDK构build工具”(最新)]build立一个平台的错误:错误:cmd:命令失败,退出代码2您可能没有所需的环境或操作系统来build立此项目错误:cmd:命令在ChildProcess.whenDone(C:\ Users \ anatf \ AppData \ Roaming \ npm \ node_modules \ cordova \ node_modules \ cordova-lib \)上的退出代码2失败,在位于maybeClose的ChildProcess.emit(events.js:98:17) .js:766:16)at Process.ChildProcess._handle.onexit(child_process.js:833:5)

我的系统信息是:

在Windows上运行

Cordova CLI:5.1.1 Ionic版本:1.0.0-beta.14 Ionic CLI版本:1.6.1 Ionic App Lib版本:0.3.3操作系统:Windows 7 SP1节点版本:v0.10.35

安装平台:android 4.0.0,浏览器3.5.2,ios 3.8.0可用平台:amazon-fireos,blackberry10,firefoxos,windows,windows8,wp8

可用的Android目标:

编号:1或“android-22”名称:Android 5.1.1types:平台API级别:22版本:2外观:HVGA,QVGA,WQVGA400,WQVGA432,WSVGA,WVGA800(默认),WVGA854,WXGA720,WXGA800,WXGA800- 7in,AndroidWearRound,AndroidWearRound400x400,AndroidWearRoundChin320x290,AndroidWearSquare,AndroidWearSquare320x320,AndroidWearRound,AndroidWearRound400x400,AndroidWearRoundChin320x290,AndroidWearSquare,AndroidWearSquare320x320标签/ ABIs:android-tv / armeabi-v7a,android-tv / x86,android-wear / armeabi-v7a,android-wear / x86,默认/ armeabi-v7a,默认/ x86,默认/ x86_64

任何人都可以帮助我?

Solutions Collecting From Web of "错误:当SDKpipe理器显示它安装时,请安装Android目标:“android-22”"

正如它评论,可能有2个不同的SDK。 看看c:/用户/ / android-sdks和c:/用户/ / / AppData /本地/ Android / android-sdks。

从我可以告诉它引用其中任何一个和它的引用缺少所需的文件。 尝试复制它们。

您需要在project.properties文件中检查targetSdkVersion和minSdkVersion。 你可以在这里找到Sebastian G. Marinescu的答案来找到完整的解决方案