Articles of 7

如何通过我的应用程序发送反馈信息到服务器?

在我的应用程序反馈表将被使用。我必须发送反馈信息到服务器。请帮助我如何发送信息到服务器在Windows手机。

在Windows 7上使用XAudio2构build

我正&#x5728;尝试使用以下说明构build一些使用XAudio2并在Windows 7上运行的代码: http://msdn.microsoft.com/en-us/library/windows/desktop/ee663275%28v=vs.85%29.aspx 正如所build议的,我将包含来自DirectX SDK的XAudio2.h: #include <%DXSDK_DIR%Include\xaudio2.h> 结果: fatal error C1083: Cannot open include file: '%DXSDK_DIR%Include\xaudio2.h': No such file or directory 好吧。 我很确定VC ++并没有像这样扩展环境variables。 所以我用直接包含它的#includereplace了#include : #include <C:/Program Files (x86)/Microsoft DirectX SDK (June 2010)/Include/XAudio2.h> (其他一些说明,也build议使用完整path,可以在这里find: http : //blogs.msdn.com/b/chuckw/archive/2012/04/02/xaudio2-and-windows-8-consumer- preview.aspx ) 结果: c:\program files (x86)\microsoft directx sdk (june 2010)\include\xaudio2.h(20): fatal error C1083: Cannot open include file: […]

在显示不同版本号的窗口上的梨

C:\PHP>pear upgrade pear pear/pear is already installed and is the same as the released version 1.9.3 upgrade failed C:\PHP>pear -V PEAR Version: 1.9.0 PHP Version: 5.2.17 Zend Engine Version: 2.2.0 正如你可以看到,梨是困惑到它正在运行的版本。 我怎样才能解决这个问题,使PEAR运行在1.9.3上? 更新 C:\PHP>pear upgrade -f pear downloading PEAR-1.9.3.tgz … Starting to download PEAR-1.9.3.tgz (295,774 bytes) …………………………………………………….done: 295,774 bytes upgrade ok: channel://pear.php.net/PEAR-1.9.3 PEAR: Optional feature […]

通过套接字接收GET请求

我怎&#x6837;才能通过套接字接收GET请求? 例如,我正在浏览器中写入: 127.0.0.1:41233/?data=mymessage 我希望我的应用程序能够接收“mymessage”。 我写了这段代码,但recv()返回WSAENOTCONN错误,我不知道如何解决它。 int main() { WSADATA socketData; SOCKET portListener; struct sockaddr_in saInfo = {0}; if ( WSAStartup( MAKEWORD(1, 1), &socketData ) != 0) { printf( "WSAStartup() error!" ); return 0; } portListener = socket( AF_INET, SOCK_STREAM, 0 ); if ( portListener == INVALID_SOCKET ) { printf( "socket() error!" ); } else { […]

在emacs中,如何执行外部命令而不是emacs进程?

对于一些外部&#x7A0B;序(不是全部),我希望程序在执行完命令之后独立运行在Emacs之外。 换句话说,如果closuresEmacs,外部程序仍然可以运行。 PS:我的操作系统是windows。

如何在Windows中使用启用伪区域进行testing?

Windows Vista引入了三个伪区&#x57DF;的概念: Pseudo Locale Locale Name LCID =================== =========== ====== Base qps-ploc 0x0501 Mirrored qps-mirr 0x09ff East Asian-language qps-asia 0x05fe 启用Base语言环境非常有用,因为您可以检查应用程序是否使用当前语言环境来格式化date,时间,数字,金钱等项目。 例如,当前的语言环境设置为Base时 ,date将被格式化为: [Шěđлеśđαỳ!!!],8ōf[Μäŕςћ!!]ōf2006 Windows的构build实际上是在伪造的 ,然后本地化为英语: 使用这些语言环境的另一个值:它testing您的应用程序不会假设16位PRIMARYLANGID由以下内容组成: 8位主要语言ID 8位的子语言ID 当实际上PRIMARYLANGID是 : 一个10位的主要语言ID 一个6位的子语言ID 或graphics: +———————–+————————-+ | Sublanguage ID | Primary Language ID | +———————–+————————-+ 15 10 9 0 bit 这三个伪区域终于走到了第8位的末端(微软已经为打破越野车应用而疲惫不堪)。 我如何在Windows中启用伪区域设置? 也可以看看 MSDN:伪地区 MSDN:使用伪区域进行本地化testing MSDN博客:Windows […]

如何在Windows 7上安装ImageMagick以使用PHP(3)

还&#x6709;其他关于如何在Windows 7上安装Imagick的线程,但目前为止还没有帮助。 🙁 (也许问题出现了更新的版本) 我已经按照以下步骤来安装: 下载并安装ImageMagick http://www.imagemagick.org/download/binaries/ImageMagick-6.8.8-1-Q16-x86-dll.exe 下载php_imagick.dll并复制到扩展名为dir(c:\ xampp \ php \ ext) http://www.peewit.fr/imagick/php55/vc11/x86/ts/php_imagick.dll 编辑php.ini文件并添加新的扩展名(c:\ xampp \ php \ php.ini) 延长= php_imagick.dll 保存ini文件并重新启动Apache(如有必要,重新启动Windows) 启动Apache并运行testing 当我启动Apache时,我得到一个popup框,显示: 程序无法启动,因为您的计算机缺lessphp5.dll。 尝试重新安装程序来解决这个问题。 然后直接在这之后再来一个: PHP启动:无法加载dynamic库'C:\ xampp \ php \ ext \ php_imagick.dll' – 指定的模块找不到。 据function,我怀疑某种编译错误。 现在我有了编译器MSVC11的PHP版本5.5.6(xampp 1.8.3),就像php_imagick.dll文件一样。 是从源代码下载ImageMagick并编译我自己的正确方式去? (从来没有在Windows编译过)

如何在Windows 7上启用FIPS

必&#x987B;从客户端testing在具有FIPS组件的计算机上工作的ac#应用程序

如何从运行Docker Toolbox(docker machine)的Windows启用Docker API访问

所&#x6709;。 运行最新的Docker Toolbox,使用最新的Oracle VirtualBox,Windows 7作为主机操作系统。 我试图启用对Docker远程API的非TLS访问,因此我可以使用在Windows上运行的Postman REST客户端,并在Docker-machine上的Docker API上运行Docker API。 我发现,如果Dockerconfiguration包括-H tcp://0.0.0.0:2375 ,那么将会在Docker机器的端口2375上暴露API,但是对于我来说,我无法find这个configuration的位置存储并可以更改。 我从工具箱的CLI执行了docker-machine ssh ,然后去了/etc/init.d/docker文件,但是没有任何文件的改变在docker-machine restart 。 我能够findUbuntu和OSX的这个问题的答案,但不能用于Windows。 谢谢。

IE6和IE7独立:它们呈现的是什么不同?

对于运行IE6和IE7的常见问题 (请参阅此问题 ),只需安装这些应用程序,就需要一个Windows(或虚拟机)框。 我怀疑这是真的(他们是真正的版本,我认为)。 我感兴趣的两个浏览器是: 来自MultipleIEs的独立IE6 安装 独立的IE7也来自Tredosoft (但在其他地方发布) 这两个加上一个“真正的”IE8安装给你三个IE版本在一个Windows安装。 我们都知道,如果你试图在一个虚拟机中可靠地运行它们,那么你运气不好,但是有人可以向我展示JS,CSS或者HTML(或者插件等)在独立的版本,因为它应该? Downvoters:我正在解决这个问题,以减less侵略性,但由于没有评论,我不知道你不喜欢这个问题。 另外:我有所有的testing用例(IE6,IE7和IE8,以及独立版本),所以如果任何人有任何代码,他们希望我testing,我可以做到这一点。