Articles of pip

当我做pip –version它显示错误为ImportError:没有名为pyparsing的模块

我尝试安装/卸载pyparsing以及它不起作用。 我坚持这一点,我也必须安装额外的库。 这是错误消息: Traceback (most recent call last): File "/usr/bin/pip", line 5, in <module> from pkg_resources import load_entry_point File "/home/rachana/.local/lib/python2.7/site-packages/pkg_resour‌​ces/__init__.py", line 72, in <module> import packaging.requirements File "/home/rachana/.local/lib/python2.7/site-packages/packaging/‌​requirements.py", line 9, in <module> from pyparsing import stringStart, stringEnd, originalTextFor, ParseException ImportError: No module named pyparsing 我怎样才能解决这个问题?

使用pip和apt-get安装软件包有什么区别?

我试图在Ubuntu机器上部署一个Django站点。 我需要安装Psycopg2和PIL,但似乎可以使用apt-get或pip来安装它们。 这两种方法在安装上有区别吗? 我知道使用pip,我可以将其安装到虚拟环境中,但使用apt-get将其安装在全局python环境中。

通过PIP安装与MKL的Scipy

我正在使用PIP与MKL一起安装Scipy以加速性能。 我的操作系统是Ubuntu 64位。 使用这个问题的解决scheme,我创build一个文件.numpy-site.cfg [mkl] library_dirs=/opt/intel/composer_xe_2013_sp1/mkl/lib/intel64/ include_dirs=/opt/intel/mkl/include/ mkl_libs=mkl_intel_lp64,mkl_intel_thread,mkl_core,mkl_rt lapack_libs= 这个文件帮助我成功安装了MKL。 但是,使用相同的上述文件,安装Scipy提示错误 ImportError: libmkl_rt.so: cannot open shared object file: No such file or directory 我也用 export LD_LIBRARY_PATH=/opt/intel/composer_xe_2013_sp1/mkl/lib/intel64 但问题仍然是一样的。 任何人都知道如何解决这个问题? 我不想手动安装Scipy,所以任何人给我一些提示,以解决它。

如何使用python2.7pip而不是默认pip

我刚刚安装了python 2.7,也点到2.7的网站包。 当我拿到版本: pip -V 表明: pip 1.3.1 from /usr/lib/python2.6/site-packages (python 2.6) 我如何使用位于以下位置的2.7版本的pip: /usr/local/lib/python2.7/site-packages

在Mac上安装libicu-dev

我如何在Mac上安装libicu-dev。 这是在文档上build议的说明 sudo apt-get install python-numpy libicu-dev http://polyglot.readthedocs.org/en/latest/Installation.html 我正在使用anaconda,但似乎总是抛出一个 In file included from _icu.cpp:27: ./common.h:86:10: fatal error: 'unicode/utypes.h' file not found #include <unicode/utypes.h> 错误

在Python中安装软件包时,pip会安装回溯错误

我有问题,使用'点'安装Python软件包,直到几天前,我没有问题,但现在突然我每次我想要安装的东西下面的错误。 我在Windows上使用Python 2.7,而且我已经重新安装“点子”了。 Traceback (most recent call last): File "C:\Python27\Scripts\pip-script.py", line 9, in <module> load_entry_point('pip==1.5.6', 'console_scripts', 'pip')() File "build\bdist.win32\egg\pkg_resources.py", line 339, in load_entry_point ns.clear() File "build\bdist.win32\egg\pkg_resources.py", line 2470, in load_entry_point else: File "build\bdist.win32\egg\pkg_resources.py", line 2184, in load raise ValueError File "C:\Python27\lib\site-packages\pip\__init__.py", line 11, in <module> from pip.vcs import git, mercurial, subversion, bazaar # noqa File […]

在windows7 64bit上运行“pip install numpy”时出现“error:Unable to find vcvarsall.bat”

我在windows7 64bit上运行pip install numpy , error: Unable to find vcvarsall.bat 我已经用pip安装了一些软件包,例如pyzmq , pysolr , enum等,所以我真的不知道哪里出了问题。 唯一可能不同的是,我已经安装.NET framework version 4.5 – >我怀疑这可能是原因,因为在一些post中,我看到它可能与Visual Studio (我没有安装) 完整的错误/追溯: Downloading/unpacking numpy Running setup.py (path:c:\users\zebra\appdata\local\temp\pip_build_zebra\numpy\setup.py) egg_info for package numpy Running from numpy source directory. warning: no files found matching 'tools\py3tool.py' warning: no files found matching '*' under directory 'doc\f2py' warning: no […]

不知道如何解决这个Cmd命令错误?

即时通讯在Windows 8上,我已经安装了最新的Python,即时通讯将使用崇高的文字3作为我的IDE创build一个网站使用flask.But首先我需要安装一个虚拟环境使用这个命令PIP安装virtualenv,这是我接受了CMD的回应。 C:\Users\osman_000>pip install virtualenv 'pip' is not recognized as an internal or external command, operable program or batch file. C:\Users\osman_000> 如果你知道如何解决这个问题,请帮助别人,因为我不知道从这里得到什么,谢谢。

如何在Windows上安装lxml

我试图用Python 3.4在我的Windows 8.1笔记本电脑上安装lmxl ,并且失败了。 首先,我尝试了简单明了的解决scheme: pip install lxml 。 但是,这不起作用。 这就是它说的: Downloading/unpacking lxml Running setup.py (path:C:\Users\CARTE_~1\AppData\Local\Temp\pip_build_carte_000\lxml\setup.py) egg_info for package lxml Building lxml version 3.4.2. Building without Cython. ERROR: b"'xslt-config' is not recognized as an internal or external command,\r\noperable program or batch file.\r\n" ** make sure the development packages of libxml2 and libxslt are installed ** […]

安装Python模块时出现Visual C ++ 10.0问题; cl.exe失败,退出状态2(h5py)

我一直在这个过去的5个小时左右。 我重新安装了一堆,但基本上我试图在运行Python 3.4.1的Windows 8.1机器上安装Python模块h5py。 堆栈如下: Collecting h5py Using cached h5py-2.6.0.tar.gz Requirement already satisfied (use –upgrade to upgrade): numpy>=1.6.1 in c:\python34\lib\site-packages (from h5py) Requirement already satisfied (use –upgrade to upgrade): six in c:\python34\lib\site-packages (from h5py) Building wheels for collected packages: h5py Running setup.py bdist_wheel for h5py: started Running setup.py bdist_wheel for h5py: finished with status 'error' […]