Articles of rubygems

OpenSuse – RubyGems安装 – 错误的文件名称

我有一个全新的安装OpenSuse 13.1安装。 ruby -v – > ruby 2.0.0p247 (2013-06-27) [x86_64-linux] gem -v – > 2.3.0 运行gem env输出如下: EXECUTABLE DIRECTORY : /usr/bin 。 这也是我的$PATH 。 我尝试按照安装指南中的描述安装sass和compass : sudo gem install sass sudo gem install compass (我需要使用sudo因为它没有工作) 唯一的问题:既不运行sass命令也不运行compass 。 过了一会儿,我发现我不得不使用sass2.0和compass2.0来运行它们。 /usr/bin中的ruby脚本在文件名末尾用2.0命名。 为什么最后用2.0命名的ruby脚本? 我怎样才能防止这个? 我想在terminal使用compass和sass 。 我没有得到任何使用谷歌的结果。

如何完全擦rubygems与铁路等

好吧,所以我决定我会很酷,并尝试使用testing版的Rails3。 然后,事情变得难以pipe理,所以我得到了rvm。 我在rvm上安装了ruby 1.9.2-head,并且正在工作,然后计算机重新启动,之后rails将无法启动。 所以我想我只是尝试运行系统ruby,并启动它的轨道。 同样的错误。 然后,我卸载了rails3并得到了rails:没有这样的文件或目录types的错误.. 所以现在我被皇家拧紧,因为rails2仍然安装,但不会卸载,因为不可见的依赖,以及许多其他随机gem。 如何彻底清除所有的ruby,以便我可以重新开始?

RVM警告! PATH没有正确设置

我刚刚在我的Mac上安装了rvm,但在全局命令中收到此警告 警告! PATH没有正确设置,'/usr/local/rvm/gems/ruby-1.9.3-p194/bin'不是第一个地方,通常这是由shell初始化文件引起的 – 检查他们的'path= .. 。'条目,它可能也有助于重新添加RVM到你的点文件:'rvm get stable –auto-dotfiles',在这个shell会话中暂时修复:'rvm use ruby​​-1.9.3-p194'。 我的$ PATHS确认警告: $echo :$PATH: :/usr/local/rvm/bin:/usr/local/heroku/bin:/usr/local/rvm/gems/ruby-1.9.3-p194/bin:/usr/local/rvm/gems/ruby-1.9.3-p194@global/bin:/usr/local/rvm/rubies/ruby-1.9.3-p194/bin:/usr/local/rvm/bin:/opt/local/bin:/opt/local/sbin:/usr/local/bin:/usr/local/sbin:/usr/bin:/bin:/usr/sbin:/sbin: 正如所build议的,我第一次尝试rvm get stable –auto-dotfiles无济于事,然后我检查了我的shell初始化文件。 我的/.bash_profile: export PATH=/usr/local/bin:/usr/local/sbin:$PATH export PATH=/usr/local/share/python:$PATH PATH=$PATH:$HOME/bin:/opt 我的/Users/User/.bash_profile似乎是罪魁祸首: export PS1="[\w]$" alias ll='ls -laGH' alias .='echo $PWD' ### Added by the Heroku Toolbelt export PATH="/usr/local/heroku/bin:$PATH" # rvm PATH=/usr/local/rvm/bin:$PATH [[ -s "$HOME/.rvm/scripts/rvm" ]] && source "$HOME/.rvm/scripts/rvm" # […]

有没有人试过从Ubuntu上安装ruby和rubygems(最好是unbuntu 9)?

Ruby on Rails网站build议在Linux下从源代码安装Ruby。 我在一个干净的Ubuntu 9安装中遇到了一些从源代码构buildruby的C库问题。 我在网上find关于在Ubuntu下安装ruby的所有说明,都涉及到使用预先打包(.deb)的ruby。 显然,这不是铁路人员推荐的。 当我做了一个干净的Ruby源代码构build时,我发现Rubygems无法安装,因为zlib扩展不起作用。 出现两个问题: 1)zlib扩展没有被build立。 解: i)确保zlib在注释源代码的extn目录下的Setup文件中取消注释 ii)确保安装了这些zlib ubuntu软件包: aptitude install zlib1g aptitude install zlib1g-dbg aptitude install zlib1g-dev aptitude install zlibc 2)在修复上面的问题1(并且做了一个干净的ruby重build)之后,zlib仍然不工作,因为扩展失败了。 你可以看到模块无法通过运行来获取输出“false”来加载: puts require 'zlib' 我观察到,这发生在extn目录中的任何其他C扩展,所以这似乎是一个更普遍的问题与这些扩展,而不仅仅是zlib特定的。 总结: 我的ruby发现发现特定于ruby的C zlib扩展,但它无法加载zlib模块。 这种行为似乎发生在/ extn中的其他扩展。 有没有办法,我可以找出为什么一个模块无法加载? 某种跟踪/详细模式?

为什么没有findsudo:bundle命令?

为什么使用sudo时找不到命令“bundle”: [root@desktop gitlab]# sudo -u git -H bundle exec rake gitlab:setup RAILS_ENV=production sudo: bundle: command not found [root@desktop gitlab]# 但不使用sudo时确实存在: [root@desktop gitlab]# bundle exec rake gitlab:setup RAILS_ENV=production Warning You are running as user root, we hope you know what you are doing. Things may work/fail for the wrong reasons. For correct results you should run […]

我怎样才能设置一个代理服务器的gem?

我无法通过命令提示符安装SASS。 我尝试下面的步骤 c:\gem install sass 我收到以下错误: ERROR: Could not find a valid gem 'sass' (>= 0), here is why: Unable to download data from https://rubygems.org/ – Errno::ECONNREFUSED: No connection could be made because the target machine actively refused it. – connect(2) (https://rubygems.org/latest_specs.4.8.gz) 请帮帮我,

Bundler:安装特定的.gem文件

有没有办法告诉Bundler安装一个特定的.gem文件,我躺在附近? 我有一个ParseTree的编译版本,我必须使用(该死的你,Windows!),但不想扩展gem文件,以便为“gem”要求添加:path =>'…'属性。

无法在Windows上安装ruby-debug gem

我在安装Ruby-Debug Gem的时候遇到了麻烦。 这个错误是什么意思? 我怎样才能解决这个问题? 谢谢 C:\Users\Steve>gem install ruby-debug Building native extensions. This could take a while… ERROR: Error installing ruby-debug: ERROR: Failed to build gem native extension. C:/Ruby19/bin/ruby.exe extconf.rb Can't handle 1.9.x yet *** extconf.rb failed *** Could not create Makefile due to some reason, probably lack of necessary libraries and/or headers. Check the mkmf.log […]

therubyracer不在Windows上安装

当试图安装gem,我得到以下错误 C:\xampp\htdocs\mg>gem install therubyracer Temporarily enhancing PATH to include DevKit… Building native extensions. This could take a while… ERROR: Error installing therubyracer: ERROR: Failed to build gem native extension. C:/RailsInstaller/Ruby2.1.0/bin/ruby.exe -r ./siteconf20150527-5032-1urwkwd. rb extconf.rb creating Makefile The system cannot find the path specified. The system cannot find the path specified. The system cannot find the […]

在Windows上的gem更新 – 是否坏了?

这是这个问题的后续。 当我在Windows上发布gem update命令时,只要它到达最新版本没有Windows二进制文件的gem,它就会尝试构build本地扩展,当然这会失败。 例如: Updating sqlite3-ruby Building native extensions. This could take a while… ERROR: While executing gem … (Gem::Installer::ExtensionBuildError) ERROR: Failed to build gem native extension. c:/ruby/bin/ruby.exe extconf.rb update checking for fdatasync() in rt.lib… no checking for sqlite3.h… no nmake 'nmake' is not recognized as an internal or external command, operable program or batch […]