Articles of Ubuntu

如何在没有root权限的情况下在Ubuntu上安装Google Test?

我试图根据这个答案安装谷歌testing在Ubuntu没有根访问,因为我需要学习和使用它的工作。 pipe理得到这些在我自己的用户文件夹中完成: $ mkdir ~/temp $ cd ~/temp $ unzip gtest-1.7.0.zip $ cd gtest-1.7.0 $ mkdir mybuild $ cd mybuild $ cmake -DBUILD_SHARED_LIBS=ON -Dgtest_build_samples=ON -G"Unix Makefiles" .. $ make 看来我已经在/ usr / src / gtest中已经有gtest了,尽pipe我不想用这个,因为不是我安装了它,而且我也不确定它的版本,也没有它的可用性。 甚至无法删除它未经许可。 该指令仍然是: $ cp -r ../include/gtest ~/usr/gtest/include/ $ cp lib*.so ~/usr/gtest/lib 我在这里错过了什么?

/etc/rc.local和〜/ .bashrc有什么区别?

这是一个Linux相关的问题。 我已经四处搜寻,但没有得到一个很好的解释。 在我看来,这两个文件configuration设置,当我login,但有什么区别? 我注意到在决定应该把两个不同的文件分开的时候,似乎有一些“规则”。 例如,如果我需要添加特定的searchpath到$ PATH,我应该在〜/ .bashrc中执行。 但如果我决定改变一些系统设置,比如 /sys/class/backlight 要么 /sys/devices/cpu/cpu#/online 那么我必须在/etc/rc.local中执行此操作,否则将无法工作。 是否因为这些configuration在用户之间不能不同? 谢谢。

缺lessDBus .service文件

我正在为自己的需求构build自定义的dbus服务,并希望在需要时自动启动dbus服务。 为此目的,我创build了这样的.service文件 [D-Bus Service] Name=com.mycompany.servicename Exec=/home/myuser/Workspace/service-start User=myuser 在这里,我只是改变了服务和可执行文件的实际名称,但这不是重点。 我已经仔细检查了真实姓名 – 完全匹配。 我已经把这个文件名为com.mycompany.servicename.service到/ usr / share / dbus-1 / services文件夹(我使用Ubuntu 11.10)。可执行文件对每个人都有x权限。 这就是问题所在 – 当我尝试启动执行的客户端时 bus = dbus.SessionBus() bus.get_object('com.mycompany.servicename','/path/to/object') 我得到dbus.exceptions.DBusException: org.freedesktop.DBus.Error.ServiceUnknown: The name com.mycompany.servicename was not provided by any .service files 在path'/path/to/object'中的'/path/to/object'在服务启动后立即注册。 我只是不明白为什么dbus无法find我的.service文件。 也许我错过了什么? 有任何想法吗? 编辑我设法让D-BUS自动启动我的脚本。 .service文件的部分应该被命名为[D-BUS Service]而不是[D-Bus service]

服务tomcat8启动失败,使用tomcat8服务启动

我使用Vagrant部署到Ubuntu Linux并尝试启动tomcat8服务。 Tomcat 8是由apt-get install tomcat8 。 当使用service tomcat8 start命令,我得到了以下错误: tomcat8.service的作业失败。 有关详细信息,请参阅“systemctl status tomcat8.service”和“journalctl -xe”。 然后我跟踪了systemctl status tomcat8.service的systemctl status tomcat8.service ,发现: ? tomcat8.service – LSB:启动Tomcat。 加载:加载(/etc/init.d/tomcat8) 有效:失败(结果:退出代码),因为周一2016-03-28 09:44:17 GMT; 5s前 文档:man:systemd-sysv-generator(8) 进程:884 ExecStop = /etc/init.d/tomcat8 stop(code = exited,status = 0 / SUCCESS) 进程:1312 ExecStart = /etc/init.d/tomcat8 start(code = exited,status = 1 / FAILURE) Mar 28 […]

实时了解localtime()和localtime_r()的时区变化

在Ubuntu 12.04.3 LTS框中,我只注意到localtime()和localtime_r()在进程生命周期中系统时区变化时的行为不同:localtime()立即获取时区变化​​,而localtime_r不是,似乎坚持在这个过程启动的时区。 这是预期的行为? 我没有看到这覆盖任何地方。 更确切地说,当我使用下面的代码… #include <stdio.h> #include <sys/time.h> #include <time.h> #include <unistd.h> int main() { while (1) { time_t t = time(NULL); struct tm *tm = localtime(&t); printf("localtime:%02d/%02d/%02d-%02d:%02d:%02d\n", tm->tm_mon + 1, tm->tm_mday, tm->tm_year + 1900, tm->tm_hour, tm->tm_min, tm->tm_sec); sleep(1); } return 0; } …并从UTC更改时区通过… # echo 'Europe/Berlin' > /etc/timezone # sudo dpkg-reconfigure –frontend […]

运行这里编译的C程序导致GLIBC库在另一台服务器上找不到错误 – 是我的错还是他们的?

这里编译的AC程序在我们的Ubuntu服务器上运行良好。 但是当其他人试图在他们特定的Linux服务器上运行它时,会出现以下错误: ./myprog-install: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by ./myprog-install) ./myprog-install: /lib/tls/libc.so.6: version `GLIBC_2.7' not found (required by ./myprog-install) 我是否需要升级我们的glibc库并重新编译? 或者他们在服务器上丢失了什么? 如果我运行apt-cache显示libc6我的Ubuntu告诉我的版本是: Package: libc6 Priority: required Section: libs Installed-Size: 9368 Maintainer: Ubuntu Core developers <ubuntu-devel-discuss@lists.ubuntu.com> Original-Maintainer: GNU Libc Maintainers <debian-glibc@lists.debian.org> Architecture: i386 Source: eglibc Version: 2.11.1-0ubuntu7.10 如果我看http://packages.ubuntu.com/hardy/libc6目前的版本似乎是2.7-10ubuntu8.1。 我很困惑的数字。 一方面2.11-1-0是比2.7-11更高的数字。 另一方面,7.10是小于8.1的数字。 这只是我升级C库包和重新编译的问题吗? 或者是其他人的服务器缺less一些需要的库在那里兼容?

提供给mysql_options()的不支持的选项

我已经在我的本地机器上安装了mysql-server和mysql-workbench,而Ubuntu 16.04作为操作系统。 我可以通过CLI连接到mysql-server,但不能通过mysql-workbench。 mysql –version mysql Ver 14.14 Distrib 5.7.12, for Linux (x86_64) using EditLine wrapper mysql-workbench –version MySQL Workbench CE (GPL) 6.3.6 CE build 511 当我尝试连接到mysql-server时,我始终从mysql-workbench中获取此错误。 Unsupported option provided to mysql_options() 请帮我理解我在做什么错误来解决这个问题,即通过mysql-workbench连接到mysql-server。

JDK可以使用apt-get install吗?

我一直在使用一台Linux机器不到两个星期,所以我对Linux非常陌生。 我也想安装Java开发工具包。 这应该怎么做? 有没有apt-get命令,还是只要点击Sun网站上的下载button? 我确信有多种方法可以做到这一点,这可能没有太大的关系,但是在安装PHP和MySQL时apt-get install工作的顺利性给我留下了深刻的印象,所以如果有正确的做法这个,我想知道。 我正在使用Ubuntu版本9.04

ulimit -t在Ubuntu下

我运行的是Ubuntu Linux(2.6.28-11-generic#42 -Ubuntu SMP Fri Apr 17 01:57:59 UTC 2009 i686 GNU / Linux),看起来命令“ulimit -t”无法正常工作。 我跑了: ulimit -t 1; myprogram “myprogram”是一个无限循环。 我希望程序在1秒后中断,但并没有停止。 我在Linux Fedora安装上尝试了同样的事情,它按预期工作。 是否需要设置一些configuration才能正常工作? – tsf

linux和unix命令有什么区别?

我是一个新手在linux / unix世界…. Linux命令类似unix命令? 也许你可以回答另外一个问题:我可以使用ubuntu在Unix中练习命令吗? 谢谢!