Articles of xampp

我可以使用header()传递查询string参数吗?

我在Windows上使用XAMPP。 我已经configurationApache将所有请求redirect到一个controller.php文件。 控制器在进行任何其他处理之前将所有请求logging到数据库,并执行其他一些操作,包括检查涉及的文件的访问权限。 大多数请求映射到一个文件,然后我用适当的头文件和一个读文件。 例如: header ( 'Content-Type: text/css' ); header ( 'Content-Length: ' . filesize ( $file ) ); readfile ( $file ); 我的问题是,如果URL包含查询string,我不知道如何将该文件传递给该文件。 http:///myswf.swf?q1 =testing映射到C:\ SWF \ myswf.swf header ( 'Content-Type: applicaton/x-shockwave-flash' ); header ( 'Content-Length: ' . filesize ( $file ) ); readfile ( $file ); 无法将q1parameter passing给SWF。 我无法修补SWF。 我应该如何调用SWF并成功地从PHP内部传递参数?

在Linux 12.04上的Lampp,Xampp中停用了MySQL

我在我的Ubuntu 12.04(Mint 13 maya)操作系统上新安装了xampp-linux-1.8.1。 当运行lampp时,我得到: /opt/lampp/lampp start Starting XAMPP for Linux 1.8.1… XAMPP: XAMPP-Apache is already running. XAMPP: Another MySQL daemon is already running. XAMPP: XAMPP-ProFTPD is already running. XAMPP for Linux started. 在:localhost / xampp / MySQL数据库被取消激活! ps -aux | grep 'mysql' Warning: bad ps syntax, perhaps a bogus '-'? See http://procps.sf.net/faq.html mysql 3159 […]

如何在XAMPP linux中启用odbc

我正在一个PHP应用程序,其中用于数据库连接,我使用odbc。 该代码在Windows中正常工作,但是当我在Linux中尝试相同的代码时,我正面临着 致命错误未定义函数odbc_connect() 我认为这个错误是因为在XAMPP上没有启用odbc。 请告诉我如何在Linux下的XAMPP中启用odbc。 提前致谢

升级在XAMPP为PHP的PHP?

我怎样才能升级我当前的PHP(仅)在XAMPP? 我需要从5.3.1升级到5.4.0

如何在XAMPP中将默认存储引擎设置为InnoDB

如何在Linux XAMPP 1.7.3中将default-storage-engine为InnoDB?

PHPMyadmin xampp错误

我拼命试图获得Linux的1.8.0 Ubuntu的12.04 LTS的xampp访问phpmyadmin。 我知道这是一个普遍的问题,但是我已经在networking上尝试了很multithreading,而且我仍然坚持着。 Xampp似乎运行良好,本地主机开始页面不错,包括链接到侧边栏的phpmyadmin。 当我按照这个链接,我得到一个403错误: 访问被禁止! 新的XAMPP安全概念: 只能从本地networking访问请求的目录。 该设置可以在文件“httpd-xampp.conf”中configuration。 如果您认为这是服务器错误,请与网站站长联系。 错误403 localhost Apache / 2.4.2(Unix)OpenSSL / 1.0.1c PHP / 5.4.4 我已经尝试了很多东西,包括修改httpd-xampp.conf,其相关的部分现在看起来像: http ://pastebin.com/J4f4tNVs 我的/opt/lampp/phpmyadmin/config.inc.php看起来像: http ://pastebin.com/5PZPXK5s 按照其他说明,我更改了/ lampp的所有权: chown -Rv nobody:root ./lampp/* 请帮帮我! 谢谢,Matt

为什么我不能在本地访问Xampp的phpmyadmin? 访问被禁止。

我可以在ubuntu上用phpmyadmin访问XAMP上的localhost。 我可以看到我完全清除并编写了自己的/ htdocs的内容。 我想访问phpmyadmin,但不能。 当加载phomyadmin时,我收到一个403错误和一个提示,build议我在文件httpd-xampp.confconfiguration设置。 我查看/opt/lampp/etc/extra/httpd-xampp.conf ,但不知道要configuration什么。 文件中的两个区域在这种情况下似乎很有用: <Directoy "/opt/lampp/phpmyadmin"> AllowOverride AuthConfig Limit Order allow,deny Deny From all </Directory> 和 # # New XAMPP security concept # <LocationMatch "^/(?:xampp|security|licenses|phpmyadmin|webalizer|server-status|server-info))"> Order deny,allow Deny from all Allow from ::1 127.0.0.0/8 \ fc00::/7 10.0.0.0/8 172.16.0.0/12 192.168.0.0/16 \ fe00::/10 169.254.0.0/16 ErrorDocument 403 /error/XAMPP_FORBIDDEN.html.var </LocationMatch> 在这两个部分,我尝试更改“拒绝从所有”到“全部允许”,并使用命令sudo /opt/lampp/lampp restart启动Xampp。 我收到了像以前一样的错误页面。 我尝试了其他在网上find的解决scheme,但都没有工作。 […]

PHP中的Mongodb连接不工作

我正在使用Ubuntu 12.04 LTS并在/opt/lampp/bin/安装了pecl。 当安装第二次抛出错误 – 先前运行的命令 – pecl install mongo pecl / mongo已经安装,并且与发布版本1.5.1安装失败相同 现在,当我正在检查 – echo extension_loaded("mongo") ? "loaded\n" : "not loaded\n"; 它显示不加载。 但是,我更新了extension=mongo.so的php.ini,并重新启动了服务器,但不工作。 让我现在做我做错了什么。 编辑 我重新实例化了命令,以下是结果 – Build process completed successfully Installing '/opt/lampp/lib/php/extensions/no-debug-non-zts-20100525/mongo.so' install ok: channel://pecl.php.net/mongo-1.5.1 configuration option "php_ini" is not set to php.ini location You should add "extension=mongo.so" to php.ini

在Windows 8上无法使用PHP邮件function发送电子邮件

我在Windows 8上安装了wamp。 有错误: 警告:mail()[function.mail]:无法连接到“本地主机”端口25的邮件服务器,在php.ini中validation您的“SMTP”和“smtp_port”设置,或者在C:\ wamp \ www \第9行的mail.php 这里是简单的源代码: <?php // The message $message = "Line 1\r\nLine 2\r\nLine 3"; // In case any of our lines are larger than 70 characters, we should use wordwrap() $message = wordwrap($message, 70, "\r\n"); // Send mail('caffeinated@example.com', 'My Subject', $message); ?> 我必须安装哪些软件通过电子邮件在Windows 8上的PHP? sendmail,msmtp或ssmtp?

在XAMPP for Windows上从CPAN安装perl模块

我很生锈的Perl,我不认为这是帮助,我在Windows上运行它。 我想安装这个模块。 我试着在这里安装一个CPAN模块的指令,但它试图安装App :: cpanminus(第一步)失败。我试着运行cpan Config::Simple ,它也没有工作。 在这两种情况下,都会失败并显示以下错误消息: Unwrapping had some problem, won't try again without force Had problems unarchiving. Please build manually Running make test Make had some problems, won't test Running make install Make had some problems, won't install CPAN只是不能使用XAMPP安装的Perl版本工作? 如果是这样,我如何升级它而不会破坏任何东西?