如何在不更改代码的情况下为Symfony2设置php CLI版本?

我的设置

  • 共享主机
  • 没有root权限
  • shell访问
  • symfony 2.1
  • 部署资源(至less,这是计划)

build_bootstrap.php使用

 #!/usr/bin/env php 

这是链接到php4 cli中

 /usr/local/bin/php 

PHP4当然不起作用。 php 5.3 cli在

 /usr/local/bin/php53 

是否有一个中心位置告诉Symfony 2.1改变环境? 与Putenv的东西? 在bashconfiguration文件中导出path?

更新:

我现在使用@ascatontheflatbuild议在我的bashrc中使用别名。

不幸的是,Symfony带来了自己的逻辑在哪里寻找的PHP二进制文件。 一种select是通过putenv设置PHP_PATH。 我将它添加到app / console和app / autoload.php中,因为这两个文件都涉及Capifony任务

Solutions Collecting From Web of "如何在不更改代码的情况下为Symfony2设置php CLI版本?"