Tensorflow推荐的系统规格?

我正在开始在我的RHEL 6.5盒子上安装Tensorflow。 但事实certificate,Tensorflow需要glibc> = 2.17,而rhel 6.5的默认glibc是2.12。

我想知道是否有人可以用最低/推荐的tensorflow系统规范来帮助我?

Solutions Collecting From Web of "Tensorflow推荐的系统规格?"

这里列出了 TensorFlow要求,但是这些不建议使用特定的操作系统或glibc版本。

支持最好的操作系统是Ubuntu 14.04 64位和Mac OS X 10.10(优胜美地)及更高版本。 目前的限制因素是Bazel支持的操作系统 ,我们用它来制作二进制包。 您可以从源代码安装Bazel ,然后从源代码安装TensorFlow来解决这些问题。 许多用户发现在Docker容器中安装TensorFlow更容易,以避免这个问题。

尽管你的系统已经老化了,你不能直接从pip安装tensorflow,但是你可以从源代码安装它。 我成功地从源安装了tensorflow。 我的系统是Redhat企业版6.0,gcc版本是6.1.0,bazel版本是0.1.4。 首先你需要安装一个新的gcc版本,然后你需要编译bazel,这是一个编译tensorflow的工具。 不要使用最新版本的bazel! 0.1.4很好。 你可以按照这个页面找到一些信息。 https://github.com/tensorflow/tensorflow/issues/110