Tensorflow r1.0:找不到满足要求tensorflow的版本

我想在Windows安装Tensorflow 1.o for python

这是我的系统的信息。

D:\>python --version Python 3.5.2 :: Anaconda 4.2.0 (32-bit) D:\>pip3 --version pip 9.0.1 from d:\web\anaconda\lib\site-packages (python 3.5)' 

但是,当我执行下面的命令时,

 D:\>pip3 install tensorflow Collecting tensorflow Could not find a version that satisfies the requirement tensorflow (from versions: ) No matching distribution found for tensorflow 

我不明白是什么问题

我尝试了另一种方式

我使用Conda时就是这种情况

 (tensorflow) D:\>pip install --ignore-installed --upgrade https://storage.googleapis.com/tensorflow/windows/cpu/tensorflow-1.0.0-cp35-cp35m-win_x86_64.whl tensorflow-1.0.0-cp35-cp35m-win_x86_64.whl is not a supported wheel on this platform. 

问题是什么?

Solutions Collecting From Web of "Tensorflow r1.0:找不到满足要求tensorflow的版本"

在Microsoft Windows上,TensorFlow需要Python 3.5 64位。 你似乎使用Python 32位。

Windows上的Tensorflow需要python 3.5。 您可以按照以下步骤在anaconda中激活python 3.5:

  1. 看看你有哪个版本的python: conda search python
  2. 如果你已经有python 3.5,那么去第3步,否则使用conda create -n py35 python=3.5 anaconda创建python 3.5
  3. 激活python 3.5使用activate py35
  4. 现在使用conda install tensorflow安装tensorflow conda install tensorflow

如果step4不工作,即“tensorflow:找不到软件包”,请按照本教程伪造conda-forge forge通道,然后尝试使用step4安装tensorflow。 它为我工作。

尝试这个

使用Anaconda进行安装

 conda create --name tensorflow python=3.5 activate tensorflow conda install jupyter conda install scipy pip install tensorflow or pip install tensorflow-gpu 

在第一行的末尾添加python = 3.5非常重要,因为它将安装Python 3.5。

我遇到了同样的问题。

以下命令解决了我的问题

 pip3 install --upgrade https://storage.googleapis.com/tensorflow/mac/cpu/tensorflow-1.0.0-py3-none-any.whl 

我得到了同样的错误

  1. 获取Python 3.5
  2. 将pip版本升级到9
  3. 安装tensorflow

它为我工作