在Ubuntu中安装八度包

任何人都可以帮我解决这个错误?

octave:4> pkg install signal-1.2.0.tar.gz error: the following dependencies where unsatisfied: signal needs optim >= 1.0.0 signal needs specfun >= 0.0.0 signal needs control >= 2.2.3 signal needs general >= 1.3.2 octave:4> pkg install optim-1.2.2.tar.gz error: the following dependencies where unsatisfied: optim needs miscellaneous >= 1.0.10 optim needs struct >= 1.0.10 octave:4> pkg install struct-1.0.10.tar.gz make: /usr/bin/mkoctfile: Command not found make: *** [fields2cell.oct] Error 127 'make' returned the following error: make: Entering directory `/tmp/oct-fDBs5k/struct-1.0.10/src' /usr/bin/mkoctfile -s fields2cell.cc make: Leaving directory `/tmp/oct-fDBs5k/struct-1.0.10/src' error: called from `pkg>configure_make' in file /usr/share/octave/3.6.2/m/pkg/pkg.m near line 1391, column 9 error: called from: error: /usr/share/octave/3.6.2/m/pkg/pkg.m at line 834, column 5 error: /usr/share/octave/3.6.2/m/pkg/pkg.m at line 383, column 9 

我需要安装信号,但我必须下载其他的工作,我注意到,但它安装结构包时被卡住。

@edit尝试安装misc〜包时出现同样的错误。

 octave:5> pkg install miscellaneous-1.2.0.tar.gz error: the following dependencies where unsatisfied: miscellaneous needs general >= 1.3.1 octave:5> pkg install general-1.3.2.tar.gz make: /usr/bin/mkoctfile: Command not found make: *** [__exit__.oct] Error 127 'make' returned the following error: make: Entering directory `/tmp/oct-CA6o4U/general/src' /usr/bin/mkoctfile __exit__.cc make: Leaving directory `/tmp/oct-CA6o4U/general/src' error: called from `pkg>configure_make' in file /usr/share/octave/3.6.2/m/pkg/pkg.m near line 1391, column 9 error: called from: error: /usr/share/octave/3.6.2/m/pkg/pkg.m at line 834, column 5 error: /usr/share/octave/3.6.2/m/pkg/pkg.m at line 383, column 9 

@edit附加信息:

 octave:6> which mkoctfile `mkoctfile' is a function from the file /usr/share/octave/3.6.2/m/miscellaneous/mkoctfile.m 

我不知道该怎么做..

Solutions Collecting From Web of "在Ubuntu中安装八度包"

你需要安装mkoctfile 。 根据你的ubuntu版本,这将在不同的软件包。 它用在octave-pkg-dev但是现在在liboctave-dev

Ubuntu和Debian把它作为单独的软件包,因为只有在你想自己构建软件包时才需要它。 他们希望你使用他们打包的Octave软件包( sudo apt-get install octave-signal )。 他们的版本将落后于实际版本,但是他们分发的八度版本也会发生同样的情况。 这是稳定性的代价。