Vagrant检测到安装的VirtualBox不受支持

stream浪者的小问题; 我已经安装了最新版本的Vagrant(Windows)。 我已经能够下载文件了。

然而,在下载这个盒子之后,我遇到了一个小问题,当inputVagrant时,它说:

“Vagrant检测到安装的VirtualBox不支持4.0,4.1,4.2,4.3”

但是我有4.3。

截图

是的,PATH var链接到VBoxManage.exe

任何帮助?

Solutions Collecting From Web of "Vagrant检测到安装的VirtualBox不受支持"

可能是这个问题 ,即VirtualBox的错误,但Vagrant 1.5(目前未发布)将尝试多次获取该版本。

所以基本上流浪不支持virtualbox的较旧版本或较新版本。

Vagrant仅支持这些版本:4.0,4.1,4.2,4.3

所以要解决这个问题,我建议你下载,如果你没有旧版本的virtualbox源代码,然后运行旧版本的安装,这将解决问题。

我已经升级到5.0.0 virtualbox,并打破了我的流浪汉箱。 我尝试了一切,但没有机会。

所以我去了,并重新安装了virtualbox版本4.30,降级良好,流浪汉正在运行。

我希望这可能有帮助。

谢谢!