无法安装Windows 7 SDK(需要已安装.NET Framework 4)

我试图在Windows 8和Windows 10机器上安装Windows 7 SDK,并得到这个错误: 在这里输入图像说明

如果我点击确定,我不能安装我需要的VC ++编译器,因为它们被禁用=(

在这个错误之后,我尝试安装.NET 4,并得到这个错误: 在这里输入图像说明

如何解决它? 有时候我可以在Windows 8上安装这个SDK,但是大多数情况下我都看到这些消息。

Solutions Collecting From Web of "无法安装Windows 7 SDK(需要已安装.NET Framework 4)"

我遇到了这个问题,或者至少你所描述的声音与我最近在Windows 10上安装在较旧的SDK上时发生的情况完全相同。我正在执行下载顶层的setup.exe文件。 和你一样看到了同样的错误。 但是与setup.exe相同的是一个名为Setup的目录。 打开该目录并执行名为SDKSetup.exe的文件。 完成这个工作后,安装应该有希望成功。

如果您已经安装了VS2010 MSVC运行时,另一个会导致您麻烦的SNAFU。 您可能需要卸载它,安装SDK,然后重新安装VS2010 MSVC运行时。