在Windows 7 x64上使用铁路路由器(最新版)安装问题(Meteor 0.8.3)

我正在尝试在Windows 7中为我的Meteor项目安装(通过克隆存储库)“铁路由器”。

(回购: https : //github.com/EventedMind/iron-router )

输出如下:

While building package `iron-router`: error: no such package: 'reactive-dict@1.0.0' error: no such package: 'deps@1.0.0' error: no such package: 'underscore@1.0.0' error: no such package: 'ejson@1.0.0' error: no such package: 'jquery@1.0.0' error: no such package: 'ui@1.0.0' error: no such package: 'iron' error: no such package: 'cmather' error: no such package: 'webapp@1.0.0' 

无论如何,这些都是%LOCALAPPDATA%/。meteor / packages中的所有股票包,因为我检查了所有的目录。

有什么想法吗? 我已经在Linux上开发了一段时间了,但是我想如果我能在Windows下工作,如果我懒得在游戏之后重新启动(双引导环境)等等,这将是很好的。

在此先感谢您的帮助。

Solutions Collecting From Web of "在Windows 7 x64上使用铁路路由器(最新版)安装问题(Meteor 0.8.3)"

changelog指定在2014-08-12刚刚发布的iron:router@0.9.0。

https://github.com/EventedMind/iron-router/blob/devel/History.md

最新版本的iron:router已更新为使用只能与流星0.9版本候选版本配合使用的新套件系统。

从你的错误日志中,我可以告诉你从repo克隆的铁路路由器版本实际上是为新的软件包系统设计的最新版本(deps@1.0.0曾经是没有版本号的deps),它抱怨说,找到它所依赖的流星核心软件包,因为你可能运行流星0.8.3而不是0.9-rc。

你需要做的是从git仓库获取iron-router v0.8.2,commit sha1是05415a8891ea87a00fb1e2388585f2ca5a38e0da

从一个特定的提交哈希克隆git repo是一个不同的主题,这里是一个让你开始的答案: 如何克隆具有特定修订/变更集的git存储库?