我可以在Windows XP或7上使用最新的.NET框架吗?

我正在开发一个必须在Windows XP,7,8(桌面模式)上运行的应用程序。 我可以使用哪个版本的.net

如果这个版本不是XP或Windows 7的默认版本,将它包含在我的应用程序安装程序中是一个好主意吗?

Solutions Collecting From Web of "我可以在Windows XP或7上使用最新的.NET框架吗?"

在Windows XP上,您可以使用最新版本的.NET(在编写本文时)。

XP 4.5不支持.NET 4.5。 .NET 4.5的系统要求

XP 4.0支持.NET 4.0。

当你安装你的应用程序时,你应该期望不得不安装框架。 dotNetInstaller对此很有帮助 (虽然也有其他方法)。

在.NET框架中可能有某些类或方法需要比XP / Vista / 7等更高版本的Windows。但是,您将不得不逐个检查这些情况。