Windows XP上的Scrapy ImportError:没有名为w3lib.html的模块

我刚刚尝试在运行Windows XP的工作环境中安装并运行scrapy

如果我运行scrapy startproject myproject,我将得到以下错误:

ImportError: No module named w3lib.html 

Wining:在Windows XP上运行Python / Scrapy真的很麻烦。 在Linux上,我只是运行PIP安装Scrapy,这是好的哈哈。

Solutions Collecting From Web of "Windows XP上的Scrapy ImportError:没有名为w3lib.html的模块"

看来他们忘了列出w3lib和simplejson。 后者仅在2.6之前的Python版本中是必需的。 这里是Distribute的安装程序,以防你没有easy_install和pip。 然后你可以使用后者中的一个来获得剩余的依赖关系。

使用easy_install w3lib为我工作

如果你安装了pip,在Mac和Linux上:

尝试:

pip安装w3lib

如果你以前用root安装过它:

sudo pip安装w3lib