如何在Windows中安装PCNTL扩展

我在Windows中运行phpunit,并试图安装phpunit

"phpunit/php-invoker":"*"

依赖,但我越来越

 phpunit/php-invoker 1.1.3 requires ext-pcntl * -> the requested PHP extension pcntl is missing from your system. 

我怎样才能安装这个扩展?

Solutions Collecting From Web of "如何在Windows中安装PCNTL扩展"

您不能在Windows上安装ext-pcntl扩展名。 根据PHP文档:

目前,该模块不能在非Unix平台(Windows)上运行。

如果你想安装PHPUnit,你只需要PHPUnit库:

 composer require phpunit/phpunit 4.* 

你不需要php-invoker来安装PUPUnit。 但是,如果你还需要php-invoker库,那么你运气不好。 尝试使用Linux发行版(如Ubuntu,Debian或Mint)中的Vagrant或普通VM。