docker工人 – 无法find包docker引擎

我正在尝试在Ubuntu 16.04中安装docker。 我正在关注docker安装的这个链接 。 我结束了无法find包窗引擎

我目前的核心版本 – 4.4.0-38 – 通用 Ubuntu版本 – 16.04

已经在Ubuntu里面的 docker.io软件包叫做docker.io [1]

 sudo apt-get install docker.io 

但是, 如果你遵循你给的链接,并执行步骤7,8,9,那么你的安装将知道在码头回购的包,也找到docker-engine

你的来电。 我在一些机器上运行Ubuntu版本(在Ubuntu 16.04上当前为0.11.2),在其他机器上运行Docker版本(因为我对0.12特性感到好奇)。 两者都可以正常工作。

[1]由于docker是用于桌面启动应用程序“对接”图标。

解决了docker中大部分问题的主要解决方案是安装64位版本的ubuntu。 我正在运行32位(i686)。 希望能帮助到你 ! !