Gulp安装:'fs:重新评估本地模块源不受支持'和node-sass错误

我有一个新的笔记本电脑,不得不重新安装吞/ NPM为了让我的网站文件在本地正常运行。 但是,当我在Windows中运行gulp命令时出现以下错误。

fs:不支持重新评估本地模块源代码。 如果您使用的是graceful-fs模块,请将其更新为更新的版本。

查看这个错误后,我看到post说我只需要运行npm update -g npm 。 此命令运行并闪烁一些信息,但在消息读取之前消失。 我认为它已经是最新的,看起来好像我刚刚安装它! 我曾尝试在全局和项目文件夹内运行此命令。

如果我运行, npm info graceful-fs -v ,我的graceful-fs版本是3.10.8

那么谁能帮忙? 我用这个东西垃圾:(

****** UPDATE *******

我决定卸载graceful-fs ,然后运行npm install

我再次跑了一口之后,

错误'libsass'未find在…

所以我然后运行npm重buildnode-sass并得到node-sass错误的负载。

请帮忙。

在这里输入图像描述

这个问题似乎是,吞咽3.x(通过vinyl-fs)使用较老版本的graceful-fs。 请参阅此链接了解更多信息。 我不知道,但你可以尝试更新gulp到4.x?