在HostGator上切换php 5.4到5.5

目前在composer php安装我得到错误需要5.5.9,但使用5.4,但在HostGator cpanal它被设置为5.5

php -v我得到

 PHP 5.4.45 

php --ini我得到

 Configuration file (php.ini) Path: /opt/php54/lib 

进入/ opt /有一个php54,php55和php56

如何将我的版本更改为5.5

我在这个链接上看到了下面的例子

 $ php -v PHP 5.4.x (cli) ... $ set PATH="/usr/lib64/php5.6/bin:$PATH" $ php -v PHP 5.6.x (cli) ... 

但是进入/ usr / lib64的时候没有php5.6

在我的web服务器的索引文件中,我做了一个phpinfo(),它被设置为5.5

任何人有任何想法

在我的hostgator共享主机上,php 5.6可执行文件位于/opt/php56/bin/php

您可以使用ls /opt来查看php版本文件夹是否存在。

所以,如果你想用5.6更新你的php命令,你应该编辑你的~/.bash_profile并附加下面一行:

 alias php='/opt/php56/bin/php' 

如果您没有看到更改,则可能必须注销并重新登录。

现在,当你使用php -v ,如果你做得对,应该说5.6.x

这与7.0的工作原理是一样的,任何其他的PHP版本应该位于相同的目录中。