无法在mysql-apt-config中select“确定”

我正在使用Ubuntu 14.04。 sudo apt-get update总是给我这个选项来configurationmysql-apt-config。

在这里输入图像说明

我已经尝试select版本,按“选项卡” – >键突出显示“确定”,按“确定”,但没有任何反应。 它会再次突出显示版本号。

Software Updater也在mysql-apt-config上崩溃。

任何想法是什么导致这个问题,以及如何摆脱它? 谢谢。

当你不能做的时候

 apt-get purge mysql-apt-config 

因为你被困住了:它不会执行,因为dpkg被中断,而“sudo dpkg –configure -a”将把你带回到“配置mysql-apt-config”页面。

编辑: /var/lib/dpkg/info/mysql-apt-config.postinst

在开始处添加exit ,然后摆脱包:

 sudo dpkg --configure mysql-apt-config sudo apt-get remove mysql-apt-config 
  • 取消当前的软件包
    1. $ sudo apt-get remove mysql-server mysql-client mysql-common
    2. $ sudo apt-get autoremove
    3. $ sudo apt-get autoclean
  • 安装依赖关系: sudo apt-get install libaio1
  • http://dev.mysql.com/downloads/repo/apt/下&#x8F7D;mysql-apt-config<version>.deb于您的安装的currect mysql-apt-config<version>.deb
  • 安装到你的系统:sudo dpkg -i mysql-apt-config<version>.deb
  • sudo apt-get install mysql-server服务器: sudo apt-get install mysql-server

关于CUI(字符用户界面):

  • 突出显示您想要的版本(使用箭头键)
  • 按“Enter”

这应该带你回到软件包列表(即不是版本号列表)。 然后:

  • 突出显示“应用”(使用箭头键)
  • 按“Enter”