为Qt创build者安装doxygen插件

我正在尝试为Qt Creator( http://dev.kofee.org/ )安装doxygen插件,但是当我启动Qt Creater时,出现以下错误

Could not resolve dependency 'Core(2.8.1)' Could not resolve dependency 'CppEditor(2.8.1)' Could not resolve dependency 'CppTools(2.8.1)' Could not resolve dependency 'Locator(2.8.1)' Could not resolve dependency 'ProjectExplorer(2.8.1)' Could not resolve dependency 'TextEditor(2.8.1)' 

我无法在Google中find有关这些错误的任何信息。 有谁知道如何解决它,或者任何人都可以build议其他插件?

回答一个老问题来记录我在这个问题上的发现。

从Qt Creator插件wiki http://qt-project.org/wiki/Qt_Creator_Plug-in_Gallery

Qt Creator使用“通过插件添加所有功能的方法”,错误消息中提到的项目是提供标准功能的“插件”。

它与doxygen插件所依赖的插件列表相匹配: http://dev.kofee.org/projects/qtcreator-doxygen/repository/entry/trunk/Doxygen.pluginspec

 <dependencyList> <dependency name="Core" version="3.1.0" compatVersion="3.1.0_1"/> <dependency name="CppEditor" version="3.1.0" compatVersion="3.1.0_1"/> <dependency name="CppTools" version="3.1.0" compatVersion="3.1.0_1"/> <dependency name="ProjectExplorer" version="3.1.0" compatVersion="3.1.0_1"/> <dependency name="TextEditor" version="3.1.0" compatVersion="3.1.0_1"/> </dependencyList> 

所以,总之,看起来您正在尝试安装为不同版本的QtCreator构建的插件版本。

http://dev.kofee.org/projects/qtcreator-doxygen/files上有这个插件的所有不同版本的列表,文件名包括它为其构建的QtCreator版本&#x3002;

例如qtcreator-doxygen- 0.3.9-qtcreator-3.1.x -linux-x86_64.tar.gz