Ruby on rails在Ubuntu上安装错误

我只是试图通过这个命令来安装rails:

sudo gem install rails

但是像这样发生错误:

Building native extensions. This could take a while... ERROR: Error installing rails: ERROR: Failed to build gem native extension.

/usr/bin/ruby1.9.1 extconf.rb /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in 'require' from extconf.rb:1:in '<main>'

Gem files will reamin installed in /var/lib/gems/1.9.1/gems/json-1.8.3 for inspection. Results logged to /var/lib/gems/json-1.8.3/ext/json/ext/generator/gem_make.out

我尝试了几次重新安装ruby,并尝试sudo apt-get update

我该怎么办?

只需按照下面的步骤,你就可以在ubuntu轻松install rails:

首先使用以下command安装rvm (我猜你已经安装了):

 $ \curl -L https://get.rvm.io | bash -s stable --ruby 

然后安装Ruby:

 $ rvm install ruby $ rvm --default use ruby-2.2.3 

然后安装Node.js for rails:

 $ sudo apt-get install nodejs 

最后,通过以下方式安装导轨:

 $ > gem install rails 

您可以使用以下方法检查安装的导轨版本:

 $ > rails -v 

我希望这有帮助。

更新:

根据@Amit先生的评论,我们可以使用下面的命令安装,ruby和rails结合为:

 \curl -sSL https://get.rvm.io | bash -s stable --rails 

Rails 4.0需要RubyGem版本2.0.3,更新你的rubygem

 gem update --system 2.0.3