RubyMine – 没有为该项目configurationRuby解释器

我去设置 – rubySDK和gem,并选出C:\RailsInstaller\Ruby1.9.3\bin\ruby.exe

它加载了一堆gem的右侧,看起来像它会工作。

我点击确定,仍然有可怕的语法突出显示,它仍然认为它没有Ruby解释器。

我已经尝试使caching无效,甚至下载新版本的ruby,并将其指向新的二进制ruby.exe文件。

当我将项目移动到运行不同版本的JRuby的另一台PC时,我遇到了这个问题。 解析度:

  1. 关闭RubyMine
  2. 删除.idea/文件夹
  3. 在RubyMine中重新打开项目

我有这个问题时,不知何故糊涂了RubyMine的.idea目录中的文件是否在混帐。 做一些事情,如git stash将打破我的RubyMine配置。 我通过recooning我的repo,从旧克隆复制.idea到新的,修复我的RubyMine配置。 之后,它保持不变。

不知道是否这就是为什么你有这个问题,但我会看看RubyMine是否有任何麻烦写文件.idea,或是否有任何改变这些文件在RubyMine的背后。

强烈建议如果你打算检查.idea文件夹(我会忽略它)尝试使用这个gitignore来正确配置它: https : //github.com/github/gitignore/blob/master/Global/JetBrains。 gitignore