Articles of 升级

由于冲突,Docker升级失败

我正试图将CentOS 7上的Docker从1.9升级到1.10。 我正在使用Docker网站上提供的脚本: https://docs.docker.com/engine/installation/linux/centos/ 我正在运行脚本: curl -fsSL https://get.docker.com/ | sh 最终,脚本执行以下命令: sudo -E sh -c 'sleep 3; yum -y -q install docker-engine' 该命令失败,出现以下消息: Error: docker-engine-selinux conflicts with docker-selinux-1.9.1-25.el7.centos.x86_64 Error: docker-engine conflicts with docker-1.9.1-25.el7.centos.x86_64 You could try using –skip-broken to work around the problem You could try running: rpm -Va –nofiles –nodigest 我已经把这个失败与yum命令隔离了,并试图用–skip-broken来运行它。 虽然这并没有太大的作用: $ sudo […]

如何升级从源代码构build的Linux软件包?

我下载了Boost v1.42源码,然后将其安装在笔记本电脑上。 我想升级到v1.45(当前版本)。 我想知道我可以通过命令行来做到这一点。 这个问题适用于从源代码构build并安装在Linux机器上的任何包。 任何帮助是极大的赞赏。 干杯… 编辑1:我使用的发行版是我的笔记本电脑上的CentOS 5和我电脑上的Debian Lenny。

提升“太旧”的热情,不会安装

我正在尝试在我的Ubuntu 14.04上安装ardor 3.0 。 我已经从他们的网站下载了源代码。 但是当我运行./waf configure它写道 Checking for boost library >= 1.39 : too old Please install boost version 1.39 or higher. The configuration failed 并中止。 经过一番search,我发现这个网站 ,解释如何在unix系统上安装boost。 我已经按照下面的说明: 第1步:安装Boost 您可以通过您的操作系统的软件包pipe理器或从源进行安装。 来自Source 这些说明将帮助您在类Unix系统上安装Boost C ++库。 如果您已经安装了它们,请确保它是您要使用的软件所需的版本。 如果没有,没问题,我们现在就build立它。 在Linux上,确保你已经安装了Python头文件(即开发信息)。 你的操作系统可能会调用这个包,像python-dev或python-devel。 接下来,下载boost释放tar.bz2文件。 要解压文件,请使用tar xfj boost_1_39_0.tar.bz2。 在OS X上,您可能需要修改几个文件才能正确构buildBoost.Python。 请参阅https://svn.boost.org/trac/boost/ticket/3930 。 然后,从boost下载目录中执行此操作: $ ./bootstrap.sh –prefix=$HOME/pool –libdir=$HOME/pool/lib –with-libraries=signals,thread,python $ […]

升级默认的python版本或者在Linux中安装另一个python版本

我想在Linux中升级python的默认版本,例如/usr/bin/python 。 我有多个Python版本安装为 /usr/bin/python2.7 /usr/bin/python3.3 但是, python命令仍然返回python2.7 # python Python 2.7 Type "help", "copyright", "credits" or "license" for more information. >>> 现在,我已经安装了一个模块,安装在默认的版本2.7 。 这就是为什么我不能使用python3.3 script.py ,因为它返回错误的模块。 如何将这个默认版本更新到3.3 ? 有没有办法在/usr/bin/python3.3安装模块? 补充:模块是pexpect-2.3 。

在CentOS上从Python2.4转换到Python2.6。 模块迁移问题

嘿家伙,我有一个从2.4升级到2.6的Python的问题: 我有CentOS 5(Full) 它有python 2.4生活在/usr/lib/python2.4/ 其他模块生活在/usr/lib/python2.4/site-packages/ 我已经在/usr/local/lib/python2.6/上创build了python 2.6。 我已经将默认的python设置为python2.6 现在2.4的旧模块是pythonpath和“丢失” 尤其是yum被打破了(“no module named yum”) 那么迁移/安装模块到python2.6的正确方法是什么?

如何升级postgresl数据库? 不兼容性错误

我通过Homebrew安装了postgresql。 升级后出现以下问题: FATAL: database files are incompatible with server DETAIL: The data directory was initialized by PostgreSQL version 9.0, which is not compatible with this version 9.1.2. 有关如何升级的任何提示? 我尝试了以下内容: $ pg_upgrade -d /usr/local/var/postgres/ -D /usr/local/var/postgres -b /usr/local/Cellar/postgresql/9.0.4/bin -B /usr/local/Cellar/postgresql/9.1.2/bin 它没有工作。 这是输出。 Performing Consistency Checks Checking current, bin, and data directories ok Checking cluster versions This […]

python点子升级rest

我正在使用Ubuntu 16.04.1 LTS。 我需要升级点到最新版本(8.1.2) 当我运行: sudo pip install -U pip 我得到以下错误。 我检查了代理,他们看起来没问题。 Exception: Traceback (most recent call last): File "/usr/lib/python2.7/dist-packages/pip/basecommand.py", line 209, in main status = self.run(options, args) File "/usr/lib/python2.7/dist-packages/pip/commands/install.py", line 328, in run wb.build(autobuilding=True) File "/usr/lib/python2.7/dist-packages/pip/wheel.py", line 748, in build self.requirement_set.prepare_files(self.finder) File "/usr/lib/python2.7/dist-packages/pip/req/req_set.py", line 360, in prepare_files ignore_dependencies=self.ignore_dependencies)) File "/usr/lib/python2.7/dist-packages/pip/req/req_set.py", line 448, in _prepare_file […]

如何在Linux上的项目中的一个共享库(.so)中修复?

我想快速修复一个项目的.so库。 重新编译.so并replace原始文件是否安全? 或者我必须重build并重新安装整个项目? 还是取决于?

无法进行menuconfig

我使用Debian 7.4 Wheezy。 我试图升级我的内核,但是当我input“make menuconfig”它说: *** Unable to find the ncurses libraries or the *** required header files. *** 'make menuconfig' requires the ncurses libraries. *** *** Install ncurses (ncurses-devel) and try again. *** make[1]: *** [scripts/kconfig/dochecklxdialog] Error 1 make: *** [menuconfig] Error 2 我试图安装“libncurses5-dev”,但我得到的错误: E: Unable to locate package libncurses5-dev PS 我手动下载并安装了软件包,现在一切正常! 非常感谢!!

如何将Linux中安装的Qt从一个版本升级到更高版本

从Qt项目移植到Linux(Ubuntu的),我面临以下问题: 在Windows上Qt版本4.8.1安装在Linux 4.6.3上 ,其中一些function尚未实现 (如QUdpSocket :: joinMultiCastGroup )。 我看到这个问题只有一个解决scheme:将Linux上的Qt版本升级到4.8.1。 我怎样才能做到这一点? 在Linux上,我已经安装了libqt4-dev,qmake。