Articles of 点

在Linux服务器上,使用get-pip.py –user来安装pip

我以用户身份ssh到Linux服务器。 不知何故,服务器安装了Python 2.7.5,但不响应which pip 。 所以我试图根据pip文档使用get-pip.py安装pip。 默认安装选项似乎有问题: $ python get-pip.py OSError: [Errno 13] Permission denied: '/usr/lib/python2.7/site-packages/pip' 所以我试了一下: $ python get-pip.py –user Collecting pip Using cached pip-9.0.1-py2.py3-none-any.whl Collecting setuptools Using cached setuptools-28.8.0-py2.py3-none-any.whl Collecting wheel Using cached wheel-0.29.0-py2.py3-none-any.whl Installing collected packages: pip, setuptools, wheel Successfully installed pip-9.0.1 setuptools-28.8.0 wheel-0.29.0 但是which pip仍然no pip in …(my PATH)产生no pip in […]

点不工作的Python 2.7

我刚才遇到了一个问题,当我尝试安装类似pip install readline东西时,我得到一个错误: Traceback (most recent call last): File "/usr/local/bin/pip", line 9, in <module> load_entry_point('pip==1.5.6', 'console_scripts', 'pip')() File "build/bdist.linux-x86_64/egg/pkg_resources/__init__.py", line 549, in load_entry_point File "build/bdist.linux-x86_64/egg/pkg_resources/__init__.py", line 2709, in load_entry_point File "build/bdist.linux-x86_64/egg/pkg_resources/__init__.py", line 2369, in load File "build/bdist.linux-x86_64/egg/pkg_resources/__init__.py", line 2375, in resolve File "/usr/lib/python2.7/dist-packages/pip/__init__.py", line 74, in <module> from pip.vcs import git, mercurial, subversion, bazaar # […]

什么是三重等号和ubuntu2在Python pip冻结?

在我的AWS Ubuntu 14.04实例上,我只是做了一个pip freeze > requirements.txt ,它给了我一个文件,其中还包括以下两行: python-apt===0.9.3.5ubuntu2 python-debian===0.1.21-nmu2ubuntu2 当我然后使用此文件在另一个AWS Ubuntu 14.04实例上执行pip install -r requirements.txt ,我得到以下回溯: Traceback (most recent call last): File "/usr/lib/python2.7/dist-packages/pip/basecommand.py", line 122, in main status = self.run(options, args) File "/usr/lib/python2.7/dist-packages/pip/commands/install.py", line 262, in run for req in parse_requirements(filename, finder=finder, options=options, session=session): File "/usr/lib/python2.7/dist-packages/pip/req.py", line 1632, in parse_requirements req = InstallRequirement.from_line(line, comes_from, prereleases=getattr(options, […]

在AP模式下扫描失败(wpa_supplicant)

我正在使用wpa_supplicant创build一个访问点: wpa_supplicant -D nl80211 -i wlan0 -c /etc/wpa_supplicant_ap.conf 问题是,当设备configuration在访问点,我不允许扫描networking: iw dev wlan0 scan command failed: Invalid argument (-22) 或者在wpa_cli中: > scan OK <3>CTRL-EVENT-SCAN-FAILED ret=-22 在dmesg: [85769.193376] CFG80211-ERROR) __wl_cfg80211_scan : Invalid Scan Command at SoftAP mode [85769.200133] CFG80211-ERROR) wl_cfg80211_scan : scan error (-22) 似乎在wl_cfg80211.c里面: if (dhd->op_mode & DHD_FLAG_HOSTAP_MODE) { WL_ERR(("Invalid Scan Command at SoftAP mode\n")); return […]

Graphviz找不到任何字体

使用graphviz进行任何操作时,出现“找不到/打开字体”错误。 我已经缩小到一个尽可能简单的图表,在文件simplest.dot : digraph G { node1 } 运行$ dot simplest.dot -Tpng -O ,graphics呈现为simplest.dot.png ,但是我总是得到这个错误: Error: Could not find/open font ,输出中使用的字体不是很漂亮。 根据graphviz常见问题,当这个错误发生时,你可以告诉graphviz在哪里寻找字体 。 我一直在寻找我使用的系统上的字体,似乎在/usr/share/fonts有一些TrueType字体,比特streamVera字体,它们似乎生活在/usr/share/fonts/bitstream-vera 。 所以我已经尝试在点图中设置fontpath和fontname ,以帮助graphviz弄清楚事情的fontpath : digraph G { fontpath="/usr/share/fonts/bitstream-vera" fontname="Bitstream Vera Sans" node1 } 但是我仍然得到完全相同的错误。 我已经尝试了几种path和字体名称的变体,但是我似乎无法正确地使用它。 我究竟做错了什么?

GCC错误:/ usr / lib / rpm / redhat / redhat-hardened-cc1:没有这样的文件或目录

[axaysd@localhost ~]$ sudo pip install lightfm [sudo] password for axaysd: Collecting lightfm Using cached lightfm-1.12.tar.gz Requirement already satisfied: numpy in /usr/lib64/python2.7/site-packages (from lightfm) Requirement already satisfied: scipy>=0.17.0 in /usr/lib64/python2.7/site-packages (from lightfm) Requirement already satisfied: requests in /usr/lib/python2.7/site-packages (from lightfm) Installing collected packages: lightfm Running setup.py install for lightfm … error Complete output from command /usr/bin/python […]

graphics对于cairo-renderer位图来说太大了

我试图使用pyreverse为项目源代码生成UML图像。 当我运行pyreverse命令,并指定生成PNG图像,它运行,然后过了一段时间,它显示: dot: graph is too large for cairo-renderer bitmaps. Scaling by 0.271394 to fit dot: graph is too large for cairo-renderer bitmaps. Scaling by 0.333083 to fit 然后,如果我打开任何图像,文本是不可读的,因为它被缩放。 有没有一种方法可以不缩放,让图像变大? 谢谢

在Windows上,各种脚本文件夹有什么区别?

在Python的Windows安装中,以下内容有何区别? "PythonInstallFolder"\Scripts\ %APPDATA%\Python\Scripts\ %APPDATA%\Python\Python36\Scripts\ 另外,都应该在我的路上? 我有多个版本的Python安装。 Python27 – > C:\Users\nahawk\Python\Python27\ Python36 – > C:\Users\nahawk\Python\Python36\ 产量 C:\>where pip C:\Users\nahawk\Python\Python27\Scripts\pip.exe C:\Users\nahawk\Python\Python36\Scripts\pip.exe C:\>where pip2 C:\Users\nahawk\Python\Python27\Scripts\pip2.exe C:\>where pip3 C:\Users\nahawk\Python\Python36\Scripts\pip3.exe C:\>where cookiecutter C:\Users\nahawk\AppData\Roaming\Python\Scripts\cookiecutter.exe C:\>where futurize C:\Users\nahawk\AppData\Roaming\Python\Scripts\futurize.exe C:\Users\nahawk\AppData\Roaming\Python\Python36\Scripts\futurize.exe

如何使'pip'使用相同前缀的Python可执行文件?

我最近下载了用于Python 2.7.10 32位的Windows MSI安装程序(为了兼容性的原因,我使用了特定的版本),并且启用了“pip”。 该工具工作正常,但它似乎硬编码的Python解释器使用的path: C:\ Python27-from-msi> scripts \ pip列表 您正在使用pip版本7.0.1,但是版本9.0.1可用。 您应该考虑通过“pip install –upgrade pip”命令进行升级。 点(7.0.1) setuptools(16.0) C:\ Python27-from-msi> cd .. C:\>将Python27-from-msi Python27-from-msi-new 1 dir(s)移动。 C:\> cd Python27-from-msi-new \ C:\ Python27-from-msi-new> scripts \ pip列表 在启动程序致命错误:无法使用'“C:\ Python27-from-msi \ python.exe”“C:\ Python27-from-msi-new \ scripts \ pip.exe”列表“ 有没有一种方法让pip拿起与pip本身相同前缀的python.exe可执行文件(即Windows上的..\python.exe )? 对于它的价值, easy_install.exe行为是一样的。 我想这些可执行文件是在安装时使用类似py2exe的东西来构build的 ,而且这是通过硬编码到Python解释器的path完成的。

点安装Django的Windows 10

试图在Windows 10上安装Django。使用pip安装Django == 1.8.3,但得到语法错误“安装”无法识别。 在其他几个地方阅读它,必须使用CMD。 试过了。 尝试了Python CMD,试图从pip.exe所在的文件夹中运行CMD。刚刚安装了Python 3.4。 点击pip.exe,另一个.exe在那里。 再次尝试pip安装。 没有。 这是Windows 10的问题吗?