Articles of 点子

Linux pip,它在哪里安装软件?

我可以使用pip freeze来查看所有安装的软件。 题: 如何使用pipfind软件所在的位置。

在Fedora 22上安装Python的TripleSec库

我试过了 pip install TripleSec 它似乎安装很好,但是当我在terminal运行triplesec我得到以下错误: import sha3 AttributeError: module object has no attribute '__get_builtin_constructor' 我已经尝试过单独安装sha3 ,但没有运气。 有什么特别的,你需要尝试?

点python不在Linux上安装模块

我一直试图安装win32api模块使用pip安装win32api,但每当我尝试,它给了我一个错误消息: 下载/解压缩win32api无法获取索引库URL https://pypi.python.org/simple/找不到满足要求的任何下载win32api正在清理…没有发现win32api的任何发行版将debugging日志存储在/根/将该.pip / pip.log 我的知识库是可以的。 帮帮我。 顺便说一下,我使用的是kali linux 2.0 32位版本

设置我的Pythonpath?

我试图运行我的博托脚本,但我得到以下错误: ImportError: No module named boto.swf.layer2 根据pip冻结我boto安装,所以我想知道这里出了什么问题。 我的Pythonpath如下: ['','/usr/lib/python2.7','/usr/lib/python2.7/plat-linux2','/usr/lib/python2.7/lib-tk','/ usr / lib /python2.7/lib-old','/usr/lib/python2.7/lib-dynload','/usr/local/lib/python2.7/dist-packages','/ usr / lib / python2。 7 / DIST-包] 我的博托道路如下: /usr/lib/python2.7/dist-packages/boto/__init__.pyc 这是否意味着这是pythonpath的某种错误? 我真的失去了如何debugging,任何input将不胜感激。

Python 3.5 setup.py egg_info失败,错误代码1

我和一个朋友试图通过DigitalOceanbuild立一个不和谐的机器人。 但是,当我们运行命令“ sudo -H pip3.5 install –upgrade -r requirements.txt ”或者其他的东西时,它总是以相同的错误结束。 我们已经尝试安装python,它已经是最新的。 这里是日志。 You may need to use sudo to install dependencies. root @ discord-bot:〜/ RadioOP#sudo -H pip3.5 install –upgrade -r requirements.txt收集https://github.com/Rapptz/discord.py/archive/async.zip (从-r要求.txt(line 1))正在下载https://github.com/Rapptz/discord.py/archive/async.zip(442kB)100%|█████████████████ ███████████████| 450kB 2.5MB / s收集youtube_dl> = 2016.4.24(from -r requirements.txt(line 2))使用cachingyoutube_dl-2016.6.3-py2.py3-none-any.whl收集aiohttp <0.22.0,> = 0.21.0(from discord.py == 0.10.0a0 – > – r requirements.txt(line 1))使用cachingaiohttp-0.21.6.tar.gz收集websockets […]

点子:了解缺less的图书馆转储

我试图在Windows 7上安装HoneyProxy 。我已经安装了Python 2.7和pip。 它说, 安装所有的依赖项 :pip安装pyOpenSSL pyasn1 Twisted Autobahn Windows用户:手动安装pyOpenSSL和Twisted的二进制文件。 我的点子名单, astropy (0.3.1) autobahn (0.8.8) beautifulsoup4 (4.3.2) cffi (0.8.2) cryptography (0.4) httplib2 (0.8) matplotlib (1.3.1) numpy (1.8.1) oauth2 (1.5.211) oauthlib (0.6.0) pip (1.5.4) pyasn1 (0.1.7) pycparser (2.10) pyopenssl (0.14) pyparsing (2.0.1) python-dateutil (2.2) pytz (2014.2) requests (2.2.1) requests-oauthlib (0.4.0) setuptools (3.4.4) simplejson (3.3.2) six […]

Python 2.7.9中的pip在哪里(Linux)

我意识到这个问题可能真的很愚蠢,但我不能为我的生活找出安装python 2.7.9时可以find点的位置。 我知道pip是捆绑在这个版本和以上,但我仍然无法find它。 我没有定期的写权限,也没有包pipe理器,所以我通过从他们的网站下载Linux二进制文件来安装Python 2.7.9,然后 ./configure –prefix=/home/me/software/python-2.7.9/myinstall/ 然后 make; make install 一切似乎工作正常,我可以在安装这种方式后运行python,但点无处可寻。 任何帮助,将不胜感激。 更新 运行python get-pip.py产生以下错误信息: ERROR:root:code for hash md5 was not found. Traceback (most recent call last): File "/home/me/software/Python-2.7.9/_centos5/lib/python2.7/hashlib.py", line 147, in <module> globals()[__func_name] = __get_hash(__func_name) File "/home/me/software/Python-2.7.9/_centos5/lib/python2.7/hashlib.py", line 97, in __get_builtin_constructor raise ValueError('unsupported hash type ' + name) ValueError: unsupported hash type md5 […]

/ usr / local / bin / python:没有名为pip的模块

我安装了点子,但如果我尝试安装一个包 python -m pip install requests 它说 /usr/local/bin/python: No module named pip 我是新来的Linux,我不知道如何找出问题所在。

使用setup.py安装.desktop文件

我有一个python应用程序,应该可以通过GUI启动,所以它必须在/ usr / share / applications /中有一个.desktop文件。 该应用程序仅支持Linux。 通常,pip将所有文件安装在一个目录中,但是可以使用data_files = []在setup.py中指定其他位置(例如.desktop文件)。 在这种情况下,这被认为是一个很好的解决scheme,或者这只应该发生在一个特定的分发包(如.rpm / .deb / .ebuild)?

为什么我没有权限在virtualenv中安装psycopg2

我的目标是提供一个在运行Ubuntu的EC2实例上使用postgres的hello world Django应用程序。 我通过sshlogin,并用这个requirements.txt克隆了一个包含Django项目的git仓库: Django==1.8.2 djangorestframework==3.1.2 psycopg2==2.6 我创build了一个virtualenv,然后当我运行(ec2_deploy_test)ubuntu@ip-172-31-22-100:~/ec2-deploy-test$ pip install -r requirements.txt ,抛出了这个exception: 收集psycopg2 == 2.6(从-r requirements.txt(第3行)) /home/ubuntu/Envs/ec2_deploy_test/local/lib/python2.7/site-packages/pip/ vendor / requests / packages / urllib3 / util / ssl .py:90:InsecurePlatformWarning:一个真正的SSLContext对象不可用。 这可以防止urllib3正确configurationSSL,并可能导致某些SSL连接失败。 有关更多信息,请参阅https://urllib3.readthedocs.org/en/latest/security.html#insecureplatformwarning 。 InsecurePlatformWarning下载psycopg2-2.6.tar.gz(367kB)100%|████████████████████████████████| 368kB 785kB / s收集软件包的构build轮:psycopg2例外:回溯(最近一次调用最后):文件“/home/ubuntu/Envs/ec2_deploy_test/local/lib/python2.7/site-packages/pip/basecommand.py” ,第223行,在main status = self.run(options,args)文件“/home/ubuntu/Envs/ec2_deploy_test/local/lib/python2.7/site-packages/pip/commands/install.py”,第291行,运行wb.build(autobuilding = True)文件“/home/ubuntu/Envs/ec2_deploy_test/local/lib/python2.7/site-packages/pip/wheel.py”,第753行,在build ensure_dir(output_dir)文件“/home/ubuntu/Envs/ec2_deploy_test/local/lib/python2.7/site-packages/pip/utils/init.py”,第70行,位于ensure_dir os.makedirs(path)文件“/ home / ubuntu / (头,模式)文件“/home/ubuntu/Envs/ec2_deploy_test/lib/python2.7/os.py”,第150行的“Envs / ec2_deploy_test / lib […]