Articles of composer php PHP

无法安装Composer – php-fpm

最后用nginx和php-fpm启动并运行Ubuntu 12.10。 现在我想用Ratchet运行一个websocket服务器,但是我需要先安装Composer。 所以我这样做: curl -s https://getcomposer.org/installer | php 就像Composer网站指示的一样,但我收到以下错误: The program 'php' is currently not installed. 我认为这可能是有关的PHP在最后,所以我把它改为php5-fpm然后告诉我: [18-Nov-2012 05:01:30] ERROR: An another FPM instance seems to already listen on /var/run/php5-fpm.sock [18-Nov-2012 05:01:30] ERROR: FPM initialization failed 有人遇到过这种情况么? 任何解决scheme 谢谢。

PHP的cli只能用“-n”

我被困在一个PHP CLI问题上: 我没有ouptut,只是一个空行,当我运行时光标正在等待指令: php -r "echo 1;" 但是当我用-n(不使用php.ini文件)运行这行时,一切正常。 php -nr "echo 1;" 我真正的问题是我的composer快捷方式(/斌/composer php)不工作了,我现在每次都必须写php -n /bin/composer 。 我在Debian Wheezy上工作,我的PHP版本是最新的(5.4.4-14)。 我重新安装了很多次php没有成功。 请,你能帮我吗?

composer php忽略$ COMPOSER_HOME

我为composer设置了环境variables,但是它仍然安装到默认的dir(〜/ .composer)。 任何人都可以告诉我,如果我做错了什么? distPoint /var/www/html/laravel # COMPOSER_HOME="/opt/composer/" distPoint /var/www/html/laravel # echo $COMPOSER_HOME /opt/composer/ distPoint /var/www/html/laravel # composer global require "laravel/installer=~1.1" Changed current directory to /root/.composer ./composer.json has been created Loading composer repositories with package information Updating dependencies (including require-dev) – Installing symfony/process (v2.6.6) Downloading: 100% – Installing symfony/console (v2.6.6) Downloading: 100% – Installing guzzlehttp/streams (2.1.0) […]

composer php全球,全系统,多用户安装

我的问题很容易理解:我有一个Debian服务器,我想以多用户方式(比如RVM)安装和使用composer 及其全局依赖项 。 我总是设法自己安装composer,并使其可供任何用户使用(当然,只要用户具有shell访问权和+ x chmod)。 我喜欢做的是,当我运行composer global require wp-cli/wp-cli ,所需的依赖关系安装在“公共”位置(例如/usr/local/.composer)。 因此,如果我在此目录上设置了正确的权限,则任何可以访问/usr/local/.composer的用户都可以使用全局依赖关系。 这足够清楚了吗? 有人在那里与anwser? 谢谢!

composer php和Linux生产服务器 – 自动加载无法正常工作

我已经试过寻找这个问题,并看到了一些答案,但没有运气… 我使用Slim Framework v3安装了composer php。 我在composer.json文件中使用PSR-4为我的文件使用自动加载,如下所示: "autoload": { "psr-4": { "App\\": "App" } } 这是我的文件夹结构: 我使用Apache 2.4在本地Mac OS X El Capitan上运行它,一切都像魔术一样工作。 但是,当我上传到我的Production Linux服务器(也与Apache 2.4),自动加载似乎非常困惑,我得到这样的错误: 警告:包含(/ home / friendsapp / public_html / vendor / composer /../../ app / Middleware / AuthMiddleware.php):未能打开stream:/ home / friendsapp / public_html / vendor /composer php/ ClassLoader.php第412行 警告:include():打开'/home/friendsapp/public_html/vendor/composer/../../app/Middleware/AuthMiddleware.php'包含失败(include_path ='。:/ usr / lib […]

composer php安装,PHP扩展GD缺失

所以我试图部署我的git项目到我的Linux服务器。 我克隆它后,我试图做一个composer php安装,让一切正常运行,但我得到一个错误这样做。 brianmcdo / image-palette dev-master需要ext-gd * – >请求的PHP扩展名gd在系统中缺失。 试图解决这个问题我正在运行: yum install php-gd 然而给我另一个错误说: 错误:php55w-与php-common-5.4.16-36.el7_1.x86_64的常见冲突您可以尝试使用–skip-broken来解决问题您可以尝试运行:rpm -Va –nofiles –nodigest 我在我的服务器上有5.5.30的PHP,我不知道是否必须做任何事情呢? 有谁知道我可以如何解决这个错误,让我的项目像它应该运行?

Symfony2 – Composer清除caching错误

当试图清除symfony2项目上的caching时,我得到这个错误消息: PHP Fatal error: Call to undefined method Symfony\Component\Console\Output\ConsoleOutput::isVerbose() in /var/staging_www/www.sciforum.net/vendor/symfony/symfony/src/Symfony/Bundle/FrameworkBundle/Command/CacheClearCommand.php on line 87 任何想法? 谢谢。 编辑: 当试图更新供应商,我收到此错误消息: Clearing the cache for the dev environment with debug true PHP Fatal error: Call to undefined method Symfony\Component\Console\Output\ConsoleOutput::isVerbose() in /var/staging_www/www.sciforum.net/vendor/symfony/symfony/src/Symfony/Bundle/FrameworkBundle/Command/CacheClearCommand.php on line 99 Script Sensio\Bundle\DistributionBundle\Composer\ScriptHandler::clearCache handling the post-update-cmd event terminated with an exception [RuntimeException] An error occurred […]

我如何安装/启用PHP phar扩展?

我正在尝试在我的KnownHost VPS上安装Composer 。 当我运行这个命令时: curl -sS https://getcomposer.org/installer | php 我得到这个错误消息: Some settings on your machine make Composer unable to work properly. Make sure that you fix the issues listed below and run this script again: The phar extension is missing. Install it or recompile php without –disable-phar 我如何安装phar扩展? 我在我的VPS上运行PHP 5.4.22。

在Ubuntu 16中缺lessphp_soap.dll

我正在尝试在Ubuntu 16上安装composer php。 curl -sS https://getcomposer.org/installer | php 并收到警告: PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php/20151012/php_soap.dll' – /usr/lib/php/20151012/php_soap.dll: cannot open shared object file: No such file or directory in Unknown on line 0 All settings correct for using Composer Downloading 1.2.0… Composer successfully installed to: //composer.phar Use it: php composer.phar 我用以下方法安装肥皂: sudo […]

安装Composer时出现语法错误?

我试图开始使用这些每个安装composer php sudo -u myuser curl -sS https://getcomposer.org/installer | php sudo -u myuser curl -s https://getcomposer.org/installer | php — –check 但都给我 Warning: Unexpected character in input: '\' (ASCII=92) state=1 in – on line 381 Warning: Unexpected character in input: '\' (ASCII=92) state=1 in – on line 386 Warning: Unexpected character in input: '\' (ASCII=92) state=1 […]