Articles of linuxmint

ImportError:没有名为opencv.cv的模块

我使用以下命令在Linux Mint上安装了opencv: sudo apt-get install python-opencv 当我尝试导入opencv模块使用: from opencv.cv import * 我收到错误: from opencv.cv import * ImportError: No module named opencv.cv 任何想法为什么这个错误正在发生,以及如何解决这个问题?

Ubuntu 14和Linux Mint 17上的通道问题

我从程序pipe理器中安装了stunnel4。 当我尝试在Ubuntu 14或Linux Mint 17上运行stunnel时,我收到下面的消息。 我有这个在CentOS6.5和MacOS X Mavericks上的工作。 不知道接下来要尝试什么。 重buildopenssl是一团糟,如果那就是问题。 idf@idf-ZBOX-ID42-BE ~ $ sudo stunnel Clients allowed=500 stunnel 4.53 on x86_64-pc-linux-gnu platform Compiled with OpenSSL 1.0.1e 11 Feb 2013 Running with OpenSSL 1.0.1f 6 Jan 2014 Update OpenSSL shared libraries or rebuild stunnel Threading:PTHREAD SSL:+ENGINE+OCSP Auth:LIBWRAP Sockets:POLL+IPv6 Reading configuration from descriptor 3 Compression not enabled […]

lapack / blas / openblas从源代码正确安装 – 用新的replace系统库

我想从源代码安装BLAS,CBLAS,LAPACK和OpenBLAS库,可以在这里下载openblas和lapack , blas / cblas 。 首先,我删除了我的系统blas / cblas和lapack库,但不幸的是,atlas库不能卸载(我可以同时拥有blas和lapack或atlas – 不能删除它们)。 我没有打扰,并开始编译下载库,因为我认为安装后,我将能够删除图集。 构build过程基于本教程。 为了完整性,我将列出步骤: OpenBLAS 。 编辑Makefile.rule(NO_CBLAS = 1,NO_LAPACK = 1,NO_LAPACKE = 1)文件后,我运行以下代码: make FC=gfortran sudo make PREFIX=/usr/local/ install CBLAS 。 在编辑Makefile.in之后(除了-lpthread我需要添加-pthread标志): make cd lib ar -x libcblas.a gfortran -lopenblas -shared -o libcblas.so *.o sudo cp libcblas.* /usr/local/lib/ LAPACK 。 编辑make.inc文件后: make lapacklib mkdir tmp […]

使用“find … -delete”仅从特殊子目录中删除图像文件

我需要从不需要的图像中清理音乐collections中的一些子目录。 我正在使用find命令使用Ubuntu 14.04和/或Linux Mint 17.2以及bash shell脚本。 目录结构(最小示例)如下所示: Tagged Artist #1 Artist #1 – An Album Artist #1 – A Track.flac cover.jpg something.png Artist #1 – [compilations] Artist #1 – A Track.flac cover.jpg something.png Artist #2 Artist #2 – Another Album Artist #2 – A Track.mp3 cover.jpg 只有在以“[compilations]”结尾的子文件夹中,我想删除所有types的jpeg和/或png图像(因为标记软件错误地将它们放在那里)。 任何发生在正常的“相册”文件夹中的图像,我也希望保持。 通过我的目录结构,名称中只有“[compilations]”的文件夹只能在“Artist”文件夹下方发生, 所以最多两层深。 我想出了以下查找命令: $ cd Tagged $ […]

AwesomeWM壁纸变化

当我在Linux Mint 13“Maya”MATE下使用Awesome-WM时,有时需要打开文件pipe理器“Caja”。 但是当我启动caja ,壁纸变成了我在MATE下设置的那个,而不是rc.lua中的rc.lua 。 我努力了 sudo gsettings set org.gnome.desktop.background draw-background false 但似乎没用。 我怎样才能让我的设置下awesome-wm? 或者我应该设置2背景相同?

如何在Linux上启动Couchbase服务器?

我是Couchbase的新手,所以我按照这个教程关于CEAN Fullstack(Couchbase,Express,Angular和Nodejs)。 我按照教程的指示下载了linux mint(deb 7)的couchbase服务器,我也成功安装并运行了couchbase作为服务。 但是这部分让我感到困惑,它说安装Couchbase Server下的第二款 安装您下载的文件并启动Couchbase服务器 。 首次启动时,它应该带您通过configuration向导。 该向导大约需要两分钟才能完成。 本教程没有定义如何启动/启动服务器。 我觉得这个问题很愚蠢,但是你怎么用GUI和pipe理面板和所有东西来启动“PHP-myAdmin-like”的couchbase服务器呢?

如何在linux mint 15 mate中重新启动“menu”?

我刚刚安装了Linux Mint 15 mate,菜单崩溃了,所以我closures了它。 现在,菜单不会出现在屏幕的左下angular,我不能通过按下Windows键将其拉起来。 如何重新启动菜单? 有没有terminal命令? 我尝试重新启动,期待它自动加载,但它没有工作。 先谢谢了。

在initrd中使用ncurses(linux mint 13 – 默认的内核)

我正在修改Mint 13(ubuntu衍生产品)的initrd。 主要想法是我制作的一个程序由本地顶级脚本运行。 也就是说,当内核启动并加载initrd时,我的程序必须在initrd中运行,并在initrd从ram中卸载之前运行。 基本上我想显示窗口和使用一些ncurses lib函数,但我得到一个错误。 我把这个库包含在我的initrd文件中。 我得到的错误是:错误打开terminal:Linux。 也许这里有人有如何解决这个问题的想法?

#include <Python.h> – 在Linux Mint上终止编译

我正在尝试在我的Linux Mint 17.2 Cinnamon上安装4Suite-XML 1.02。 我下载了tar.gz文件,提取它,在提取的目录中打开一个terminal,使用sudo su切换到root shell,然后运行python setup.py install 。 我得到这个作为输出: running install running build running config running build_py running build_ext building 'Ft.Lib.number' extension x86_64-linux-gnu-gcc -pthread -fno-strict-aliasing -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -fPIC -I/usr/include/python2.7 -c Ft/Lib/src/number.c -o build/temp.linux-x86_64-2.7/Ft/Lib/src/number.o Ft/Lib/src/number.c:7:20: fatal error: Python.h: No such file or directory #include <Python.h> ^ compilation terminated. error: […]

错误:modinfo:找不到模块

我在redhat 6机器上安装新的kernel 3.12.x 下面是我遵循的安装新内核的步骤。 从/usr/src/ directory提取内核 切换到cd /usr/src/linux-3.12.x make menuconfig 保存默认configuration文件 make make modules_install make install 在这个过程中,我收到以下错误: ERROR: modinfo: could not find module fuse ERROR: modinfo: could not find module autofs4 ERROR: modinfo: could not find module target_core_iblock ERROR: modinfo: could not find module target_core_file ERROR: modinfo: could not find module target_core_pscsi ERROR: modinfo: could […]