Articles of pip

/ usr / bin / ld:找不到-lpython3.5m

我想从terminal安装tifffile包: pip install tifffile 我收到以下错误 gcc -pthread -shared -L/home/l-01-314/anaconda3/lib -Wl,-rpath=/home/l-01-314/anaconda3/lib,–no-as-needed build/temp.linux-x86_64-3.5/tifffile/_tifffile.o -L/home/l-01-314/anaconda3/lib -lpython3.5m -o build/lib.linux-x86_64-3.5/tifffile/_tifffile.cpython-35m-x86_64-linux-gnu.so /usr/bin/ld: cannot find -lpython3.5m collect2: error: ld returned 1 exit status error: command 'gcc' failed with exit status 1 任何想法,为什么我得到这个错误?

在本地安装jupyter之后,我无法运行jupyter笔记本

在linux上redhat:我试图在本地安装jupyter: $ pip install jupyter –user 似乎一切都安装正确… 但是 – 我不能runt jupyter笔记本 ,也不能〜/ .local / bin / jupyter笔记本为什么? 安装… $ pip install jupyter –user收集jupyter使用caching的jupyter-1.0.0-py2.py3-none-any.whl需求已经满足:〜/ .local / lib / python2.7 / site-packages中的ipywidgets(来自jupyter)需求已经满足:笔记本在〜/ .local / lib / python2.7 / site-packages(来自jupyter)需求已经满足:ipykernel在〜/ .local / lib / python2.7 / site-packages(来自jupyter)满足:qtconsole在〜/ .local / lib / python2.7 / site-packages(从jupyter)要求已经满足:〜/ .local / lib / […]

在Python2.7中获取pip包

我已经在我的RHEL6.7机器上安装了python2.7,它的默认是python2.6。 然后我使用命令sudo yum install python-pip安装了pip软件包。 现在pip包只能在python2.6中使用,而不能在python2.7中使用。 我怎样才能得到安装在python2.7 pip软件包?

test_venv失败Python 3.6.1安装

我刚刚安装了Linux Mint 18.1(所以我是Linux新手,我不知道我在做什么!),我试图安装Python 3.6.1。 但是,其中一个安装testing失败 – test_venv。 这里是日志: running build running build_ext INFO: Can't locate Tcl/Tk libs and/or headers warning: building with the bundled copy of libffi is deprecated on this platform. It will not be distributed with Python 3.7 Python build finished successfully! The necessary bits to build these optional modules were not found: […]

在高山Linux上安装python的问题

当我试图在高山linux上安装Snappy时使用:pip install snappy当我尝试安装一个名为cypari的必需软件包时,出现以下错误。 我安装了“apk添加snappy” gcc -fno-strict-aliasing -Os -fomit-frame-pointer -g -DNDEBUG -Os -fomit-frame-pointer -g -fPIC -Ilibcache/pari64/include -I/usr/include/python2.7 -c cypari_src/_pari.c -o build/temp.linux-x86_64-2.7/cypari_src/_pari.o In file included from cypari_src/_pari.c:460:0: cypari_src/implementation.c:47:22: fatal error: execinfo.h: No such file or directory #include <execinfo.h>

Django MySQLClient pip在Linux上编译失败

从v1.8开始,Django文档build议使用mysqlclient连接器作为框架。 我正在尝试用Python 3.4在Ubuntu 14.04上安装这个软件包,并运行到一个我无法find引用的GCC错误。 我不是编译软件的专家,所以希望有人能看到解决scheme。 我相信我得到一个链接错误。 我已经安装了发行版特定的mysql头文件,但看起来他们只适用于Python 2.7.x. 不知道多less这是有用的,所以长期粘贴道歉,但这里的错误日志: Using version 1.3.6 (newest of versions: 1.3.6, 1.3.5, 1.3.4, 1.3.3, 1.3.2, 1.3.1, 1.3.0) Downloading from URL https://pypi.python.org/packages/source/m/mysqlclient/mysqlclient-1.3.6.tar.gz#md5=58d7c9c617a4286a88db290e7857d3aa (from https://pypi.python.org/simple/mysqlclient/) Running setup.py (path:/tmp/pycharm-packaging4.tmp/mysqlclient/setup.py) egg_info for package mysqlclient running egg_info creating pip-egg-info/mysqlclient.egg-info writing dependency_links to pip-egg-info/mysqlclient.egg-info/dependency_links.txt writing top-level names to pip-egg-info/mysqlclient.egg-info/top_level.txt writing pip-egg-info/mysqlclient.egg-info/PKG-INFO writing manifest file 'pip-egg-info/mysqlclient.egg-info/SOURCES.txt' warning: […]

安装encryption失败,在安装“unicode”错误

我正在尝试安装cryptography和其unicode错误的失败。 [root@localhost root]$ pip install "cryptography>=0.2.1" Downloading/unpacking cryptography>=0.2.1 Downloading cryptography-0.5.4.tar.gz (320kB): 320kB downloaded Running setup.py (path:/home/nileshkumar-govindbhai.patel/workspaces/gozer/horizon/.venv/build/cryptography/setup.py) egg_info for package cryptography Package libffi was not found in the pkg-config search path. Perhaps you should add the directory containing `libffi.pc' to the PKG_CONFIG_PATH environment variable No package 'libffi' found Package libffi was not found in the pkg-config […]

点和pip3 – 都指向python3.5?

今天我开始尝试阴影 。 并在我的Ubuntu 16.04系统上安装python2和python3; 使用: sudo pip install shade 分别 sudo pip3 install shade 两个命令都通过了 我没有真正注意。 然后我试着运行这个小testing脚本: from shade import * simple_logging(debug=True) conn = openstack_cloud(cloud='myopenstack') images = conn.list_images() for image in images: print(image) 使用python3,我得到了一个证书错误(这是好的,我会惊奇地发现我们的内部基础设施使用正确的证书)。 但是可以肯定的是,我也想用python2.7来运行; 我被告知: ImportError:没有模块命名为阴影 所以,我仔细看看pip和pip3有什么要说的: > pip -V pip 9.0.1 from /usr/local/lib/python3.5/dist-packages (python 3.5) > pip3 -V pip 9.0.1 from /usr/local/lib/python3.5/dist-packages (python […]

Openshift 权限被拒绝

我遇到了一个完全相同的问题,这个链接说: pip安装在OpenShift失败,错误信息是权限被拒绝 。 我在将django-oscar部署到openshift时遇到了错误。 为了简化这个问题,我做了一个新的墨盒testing。 然后通过ssh访问我的openshift服务器,执行下一个命令: pip install django-oscar 。 它有一个好的开始,但是结果如下: mrju@mrju:~/Documents/My_Project/My_Website/Oscar_Test$ rhc app create oscartest python-2.7 RSA 1024 bit CA certificates are loaded due to old openssl compatibility Application Options ——————- Domain: mrju Cartridges: python-2.7 Gear Size: default Scaling: no Creating application 'oscartest' … done Waiting for your DNS name to be available … […]

安装点失败

我正在使用redhat 5.3 我使用以下命令来更新Python到2.7。 (这是更新之前的Python 2.4) # xz -d Python-2.7.6.tar.xz # tar xvf Python-2.7.6.tar # cd Python-2.7.6/ # ./configure # make && make install 我安装python-setuptools # yum install python-setuptools 然后我安装pip打印错误 ^ SyntaxError: invalid syntax File "/usr/lib/python2.4/site-packages/pip-1.5.6-py2.4.egg/pip/_vendor/colorama/__init__.py", line 2 from .initialise import init, deinit, reinit ^ SyntaxError: invalid syntax File "/usr/lib/python2.4/site-packages/pip-1.5.6-py2.4.egg/pip/_vendor/colorama/winterm.py", line 2 from . import win32 […]