Articles of yum

可以重新编译这个包吗?

你好我问这个问题的超级用户,但我没有得到一个很好的问题,我真的需要答案。 我知道你们中的一些人可以回答这个问题。 我已经通过yum安装了nginx。 现在我想添加一个模块,但我必须再次编译源代码,并包含新的模块。 但我找不到来源。 有人知道我需要做什么来重新编译源代码并获取模块。 更新 我做了帕特里克答案中的所有事情,结果非常好。 但是,现在当我运行yum更新时,它想要使用相同的版本更新已安装的rpm。 我可以让它更新,或者我应该指定它已经是最新的。

如何在Linux RHEL 4上安装yum软件包?

当我在Linuxterminal上运行root @ localhost#yum install package_name命令时,它会给出: bash: yum: command not found 因为我没有yello更新和修改包安装在我的Linux上。 为此,我挂载了我的linux iso光盘,并写入命令 root@localhost# cd /meida/RHEL_4/i386/ Disk/ 1/ root@localhost RHEL_4 i386 Disk 1# ls 但是没有包目录。 和我没有find任何http urlforms下载(wget)yum.xxxrpm。 我有Linux RHEL 4 AS版本安装。 PLZ的帮助

单声道3.2.3需要更新版本的glibc

我正在使用Red Hat并尝试从http://download.mono-project.com/archive/3.2.3/linux/x64/安装最新的Mono版本。 我用下面的命令尝试安装mono核心: sudo yum install http://download.mono-project.com/archive/3.2.3/linux/x64/mono-core-3.2.3-0.x86_64.rpm 以下是我的错误消息: Error: Package: mono-core-3.2.3-0.x86_64 (/mono-core-3.2.3-0.x86_64) Requires: libc.so.6(GLIBC_2.15)(64bit) Error: Package: mono-core-3.2.3-0.x86_64 (/mono-core-3.2.3-0.x86_64) Requires: libc.so.6(GLIBC_2.16)(64bit) Error: Package: mono-core-3.2.3-0.x86_64 (/mono-core-3.2.3-0.x86_64) Requires: libc.so.6(GLIBC_2.14)(64bit) Error: Package: mono-core-3.2.3-135.2.x86_64 (Mono_Factory) Requires: libc.so.6(GLIBC_2.16)(64bit) 我在我的操作系统中有glibc 2.12。 但是Mono需要2.16。 如果我尝试更新glibc,我可能会遇到内核问题。 在这种情况下我有什么select? 有什么办法可以解决这个问题吗?

在centOS 6.4 64bit安装teamviewer时出现依赖关系错误?

你好我正在使用centos 6.4 64bit。 我正在尝试安装teamviewer。 我已经从Teamviewer站点下载了teamviewer rpm。 当我跑步 rpm -ivh teamviewer_10.0.37742.i686.rpm 它显示我failed dependencies错误,所以我开始通过使用yum安装依赖项,但一些依赖项无法安装哪些 warning: teamviewer_10.0.37742.i686.rpm: Header V4 DSA/SHA1 Signature, key ID 72db573c: NOKEY error: Failed dependencies: libfontconfig.so.1 is needed by teamviewer-10.0.37742-0.i686 libjpeg.so.62 is needed by teamviewer-10.0.37742-0.i686 libXinerama.so.1 is needed by teamviewer-10.0.37742-0.i686 libXrandr.so.2 is needed by teamviewer-10.0.37742-0.i686 libXrender.so.1 is needed by teamviewer-10.0.37742-0.i686 当我运行yum install libfontconfig.so.1 我有这个错误 warning: […]

在Python2.7中获取pip包

我已经在我的RHEL6.7机器上安装了python2.7,它的默认是python2.6。 然后我使用命令sudo yum install python-pip安装了pip软件包。 现在pip包只能在python2.6中使用,而不能在python2.7中使用。 我怎样才能得到安装在python2.7 pip软件包?

要求:主机名,而试图安装鱼壳

我试图在更新的Amazon Linux机器上安装Fish Shell,我不断收到错误消息: Requires: hostname 我尝试了在Fish Shell网站上为CentOS 6和7提供的两个存储库,在尝试另一个之前删除这两个存储库。 Nettools已安装,它是标准的Amazon Linux安装,因此它具有所有的基础知识。 如果任何人都可以帮助,将不胜感激! 提前致谢!

yum安装ffmpeg找不到repomd.xml

我试图通过执行以下操作在EC2实例上安装ffmpeg: (1)编辑:'/etc/yum.repos.d/dag.repo'并插入: “[DAG] name = Red Hat Enterprise Linux的Dag RPM存储库 baseurl = http://apt.sw.be/redhat/el $ releasever / en / $ basearch / dag gpgcheck = 1 启用= 1' (2)运行“yum更新” 我收到错误' http://apt.sw.be/redhat/el8/en/i386/dag/repodata/repomd.xml :[错误14] HTTP错误404:未find'。 有没有人知道什么是正确的url? 在此先感谢您的帮助。

R redhat卸载

我试图卸载R在红帽6.我成功地能够安装,但在尝试安装一些非R包的过程中,我最终删除了一些目录,显然包含R源文件,现在我不能删除R或重新安装它。 当我尝试运行RI时得到这个消息: /usr/bin/R: line 236: /usr/lib64/R/etc/ldpaths: No such file or directory yum删除R给出了这个: Downloading Packages: Running rpm_check_debug Running Transaction Test Transaction Test Succeeded Running Transaction Erasing : R-3.1.2-1.el6.x86_64 1/1 Verifying : R-3.1.2-1.el6.x86_64 1/1 Removed: R.x86_64 0:3.1.2-1.el6 但是当我尝试用yum安装R安装RI时得到: Downloading Packages: R-3.1.2-1.el6.x86_64.rpm | 23 kB 00:00 Running rpm_check_debug Running Transaction Test Transaction Test Succeeded Running Transaction Installing : […]

安装特定的Ruby版本

如何使用YUM安装特定的Ruby版本(比如1.9.3-p194)? 比如yum install ruby –version ? 这样的事情可能使用YUM吗?

Linux CentOS YUM错误软件包需要 – libcrypto.so.10(OPENSSL_1.0.1_EC)(64位)

当我尝试做一个“yum更新”,我不确定如何解决时,我收到错误。 以下是错误消息: –> Finished Dependency Resolution Error: Package: nginx-1.4.7-1.el6.ngx.x86_64 (nginx) Requires: libcrypto.so.10(OPENSSL_1.0.1_EC)(64bit) 当我尝试升级时(我认为这是最好的一步),这就是“无事可做” – 就像使用下面这行: 喜欢: sudo yum reinstall openssl 要么: sudo yum install http://mirror.centos.org/centos/6/os/x86_64/Packages/openssl-1.0.1e-15.el6.x86_64.rpm Examining /var/tmp/yum-root-qbBKfF/openssl-1.0.1e-15.el6.x86_64.rpm: openssl-1.0.1e-15.el6.x86_64 /var/tmp/yum-root-qbBKfF/openssl-1.0.1e-15.el6.x86_64.rpm: does not update installed package. Error: Nothing to do 我已经尝试清理YUM数据库 rpm -e –justdb –nodeps openssl 和 sudo rpm -ivh –force http://mirror.centos.org/centos/6.5/updates/x86_64/Packages/openssl-1.0.1e-16.el6_5.4.x86_64.rpm 当我运行“rpm -q –provides openssl”时,这些都出现在所需的软件包上,但是我在YUM中得到这个错误信息: sudo […]