yii2 composer.phar更新不起作用

我在Windows 8上使用xampp,我想运行composer.phar update安装Yii2-user根据这里的描述:

 http://yii2-user.readthedocs.org/en/latest/getting-started/installation.html 

但是当我这样做,没有更新发生。 相反,我用composer显示了composer php的版本号和可能的命令列表。 没有错误消息, update在可能的命令列表中。

我也尝试了composer update ,但是,我得到一个错误消息:

  Problem 1 - yiisoft/yii2 2.0.1 requires bower-asset/jquery 2.1.*@stable | 1.11.*@stabl e -> no matching package found. - yiisoft/yii2 2.0.0 requires bower-asset/jquery 2.1.*@stable | 1.11.*@stabl e -> no matching package found. - yiisoft/yii2 2.0.1 requires bower-asset/jquery 2.1.*@stable | 1.11.*@stabl e -> no matching package found. - Installation request for yiisoft/yii2 * -> satisfiable by yiisoft/yii2[2.0 .0, 2.0.1]. Potential causes: - A typo in the package name - The package is not available in a stable-enough version according to your min imum-stability setting see <https://groups.google.com/d/topic/composer-dev/_g3ASeIFlrc/discussion> f or more details. 

好像你错过了这个命令的执行:

 composer global require "fxp/composer-asset-plugin:~1.1.1" 

它只能执行一次。

你可以在官方文档和插件Github 页面找到更多关于它的信息。

这个问题是自2014年以来递归,像其他比AssetsManager,权限….和一些PHP警告或致命的,在安装开始。 我不知道其他地方是如何“作曲家”。 但坦率地说,Yii2是一场灾难。 然后,因为yii2已经不需要它的错误。 2的积累是一场灾难。 所以…

 composer global require "fxp/composer-asset-plugin:~1.0" 

有了〜你得到了composer-asset-plugin的最后一个版本…但是这通常不够!